OPENCR not booting

asked 2023-05-05 14:44:30 -0500

jtrue gravatar image

I am currently having some issues with my OPENCR board, and I was hoping to get some help troubleshooting the problem. I am using a Raspberry Pi 4 connected to the OPENCR board via the Raspberry Pi’s USB port. Here are the symptoms of the issue:

  1. The OPENCR board does not appear to be booting up properly. The status light on the board is always off unless I reset it, in which case it seems to work okay.
  2. When I try to upload code through the Arduino IDE, I get an error stating that the port could not be found.
  3. I have tried reinstalling the firmware by resetting the board and uploading test scripts via the Arduino IDE. I have also tried reinstalling the software multiple times using the Raspberry Pi.
  4. On the bringup step, I get an error when running “ros2 launch turtlebot3_bringup robot.launch.py” stating that “ld08_driver” is not found, even though it is in the home directory.

Based on these symptoms, I suspect that there may be a firmware problem with the OPENCR board, but I haven’t been able to successfully reinstall it. Can anyone offer any suggestions for how to troubleshoot this issue and get my OPENCR board working properly?

edit retag flag offensive close merge delete