OMPL library not loaded - Move group process has died

asked 2023-03-20 23:51:32 -0600

tokyoUR10 gravatar image

updated 2023-03-27 01:16:12 -0600

I am using ROS Noetic on Ubuntu 20.04 (focal) and am setting up a UR10e with the moveit setup assistant. Upon launch (roslaunch ...) rviz is opened fine but i get the error message that move_group process has died.

[move_group-4] process has died [pid 7833, exit code -11, cmd /home/johann/ws_moveit/devel/lib/moveit_ros_move_group/move_group --debug __name:=move_group __log:=/home/johann/.ros/log/91b2d046-c79d-11ed-80a5-b5624a053193/move_group-4.log]. log file: /home/johann/.ros/log/91b2d046-c79d-11ed-80a5-b5624a053193/move_group-4*.log

I have tried to go back to the general tutorials and followed it exactly MoveIt Tutorial using the panda arm and am now experiencing the same issues at the tutorial stage (this was not the case before). Rviz also posts a warning ("Planning Scene: requesting intial scene failed") but I have had no luck with work-arounds. One thing I tried was setting the pipeline:=chomp and that was able to deal with some of the tutorial issues. Another issue seems to be that the OMPL planning interface is not loaded and I am unsure how to check the proper way to initialize it.

[ERROR] [1679371672.445353761]: Exception while loading planner 'ompl_interface/OMPLPlanner': Failed to load library /home/person/ws_moveit/devel/lib/ Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = cannot open shared object file: No such file or directory) Available plugins: chomp_interface/CHOMPPlanner, lerp_interface/LERPPlanner, ompl_interface/OMPLPlanner, pilz_industrial_motion_planner::CommandPlanner

Any and all advice would be greatly appreciated.

edit retag flag offensive close merge delete