ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

ROS2 Humble Turtlebot 3 Does anyone know what else is missing?

asked 2023-03-10 02:00:10 -0600

Fiola gravatar image

I am using a Raspberry pi 4 running Ubuntu 22.04. On this I have installed ROS2 Humble Hawksbill. The setup of the robot corresponds to a Turtlebot3 in the Burger configuration. On this I use the turtlebot3 package in the hotfix-humble branch. https://github.com/ROBOTIS-GIT/turtle.... I have the tutorial from Robotis reasonably through. What still does not work properly is the Colcon build; which throws the following error:

warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 1.16.0-unknown is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 1.1build1 is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 0.1.43ubuntu1 is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.

warnings.warn(

Finished <<< turtlebot3_example [16.9s] --- stderr: my_package
/usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.

warnings.warn(

Finished <<< my_package [10.4s] --- stderr: turtlebot3_teleop
/usr/lib/python3/dist-packages/setuptools/command/easy_install.py:158: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools. warnings.warn( /usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools. warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 1.16.0-unknown is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 1.1build1 is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/pkg_resources/__init__.py:116: PkgResourcesDeprecationWarning: 0.1.43ubuntu1 is an invalid version and will not be supported in a future release warnings.warn( /usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.

warnings.warn(

Finished <<< turtlebot3_teleop [15.7s] --- stderr: py_pubsub
/usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.

warnings.warn(

Finished <<< py_pubsub [10.0s]

Summary: 8 packages finished [21.1s] 1 package failed: turtlebot3_hardware 5 packages had stderr output: my_package py_pubsub turtlebot3_example turtlebot3_hardware turtlebot3_teleop 1 package not processed

In addition, the bringup doesn't do much for me either. This is what happens: ros2 launch turtlebot3_bringup robot.launch.py

edit retag flag offensive close merge delete

Comments

The setuptools issues are warnings and do not prevent your build.

Your error is in hardware (1 package failed: turtlebot3_hardware), but that is not shown on your question.

Post only that error message, the rest are "red herrings".

dcconner gravatar image dcconner  ( 2023-08-03 13:01:09 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-05-16 22:06:17 -0600

downgrade the version of setuptools

pip install setuptools==58.2.0

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2023-03-10 02:00:10 -0600

Seen: 700 times

Last updated: Mar 10 '23