Ask Your Question
0

installing KnowRob

asked 2012-08-13 22:35:03 -0500

Astronaut gravatar image

updated 2012-08-14 03:10:01 -0500

Hello

I tried to install KnowRob package (http://ias.cs.tum.edu/kb/wiki/index.php/Tutorial:_KnowRob_basics) but got some errors. First I check the two repositories. git clone http://code.in.tum.de/git/ias-common.git svn co http://code.in.tum.de/pubsvn/knowrob/tags/latest

everything was fine

than using http://ias.cs.tum.edu/kb/wiki/index.php/Tutorial:_KnowRob_basics tried to satisfy the system dependences rosdep satisfy knowrob

Got the error. rosdep: command not found

After that tried to do sudo apt-get install [...] # only if something is missing

And got lots error massages like this

ine1.2: Recommends: ttf-mscorefonts-installer but it is not going to be installed Recommends: gnome-exe-thumbnailer but it is not going to be installed or kdebase-runtime but it is not going to be installed Recommends: winetricks but it is not installable Recommends: wisotool but it is not installable Conflicts: wine1.0 but 1.0.1-0ubuntu13 is to be installed wine1.2-dev: Conflicts: wine1.0-dev but 1.0.1-0ubuntu13 is to be installed wine1.2-gecko: Conflicts: wine1.0-gecko but 0.1.0-0ubuntu1 is to be installed wmppp.app: Depends: ppp but it is not going to be installed wx2.6-i18n: Conflicts: wx-i18n wx2.8-i18n: Conflicts: wx-i18n E: Broken packages

So finally with executing the make command I got this errors

[ rosmake ] rosmake starting...
[ rosmake ] No package specified. Building stack ['KnowRob']
[ rosmake ] Packages requested are: ['KnowRob']
[ rosmake ] Logging to directory /home/bojan/.ros/rosmake/rosmake_output-20120814-103359 [ rosmake ] Expanded args ['KnowRob'] to: ['srldb', 'comp_temporal', 'knowrob_omics', 'jpl', 'thea', 'knowrob_actions', 'mod_probcog', 'comp_orgprinciples', 'knowrob_objects', 'semweb', 'mod_srdl', 'comp_spatial', 'bosch_semantic_map', 'ias_prolog_addons', 'ias_semantic_map', 'knowrob_cad_models', 'knowrob_common', 'navp_action', 'annotation_srvs', 'vision_srvs', 'triangle_mesh_msgs', 'ias_table_msgs', 'cogman_msgs', 'vision_msgs', 'tf_prolog', 'mod_vis', 'comp_cop', 'rosprolog', 'json_prolog', 'comp_germandeli', 'ias_knowledge_base', 'knowrob_cad_parser'] cannot find required resource: client_rosjava_jni

Any help???

edit retag flag offensive close merge delete

Comments

1

Please tag your question correctly, i.e. add the tag knowrob.

Lorenz gravatar image Lorenz  ( 2012-08-14 02:36:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2012-08-14 02:50:18 -0500

moritz gravatar image

Usually, it's good practice to fix the first error first, in this case the "rosdep: command not found". Google or the ROS wiki search will give you instructions how to install rosdep (e.g. http://www.ros.org/wiki/rosdep).

The line "sudo apt-get install [...] # only if something is missing" was not intended to be typed in literally, but means that you should install those packages that rosdep reported as missing.

Moritz

edit flag offensive delete link more

Comments

ok. Thanks. Works now

Astronaut gravatar image Astronaut  ( 2012-08-14 16:09:16 -0500 )edit
1

Can you then please mark the question as 'answered'? (or rather mark the answer as 'correct')

moritz gravatar image moritz  ( 2012-08-14 16:49:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-13 22:35:03 -0500

Seen: 597 times

Last updated: Aug 14 '12