rviz Window Does Not Open

asked 2023-02-09 12:29:22 -0500

andya gravatar image

I have installed ros and trying to start the moveit tutorials, but when I run ros the rviz window does not open and there are no obvious error messages.

I am using an Ubuntu 22.04.1 LTS 64-bit virtual machine.

I followed these Debian installation instructions: https://docs.ros.org/en/rolling/Insta... and the talker and listener test worked fine.

I then followed these instructions: https://moveit.picknik.ai/humble/doc/...

I did find that I had to do the following which were not listed on that page:

$ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/ros/humble/lib/
$ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/ros/humble/lib/x86_64-linux-gnu/

This is the command I am running:

$ ros2 launch moveit2_tutorials demo.launch.py rviz_tutorial:=true

and no rviz window appears. The tail end of the output is below (not enough 'points' to attach text files).

To make sure graphics were working I installed glxgears and that runs fine with 65 FPS.

These are now the additional lines in my .bashrc

source ~/ws_moveit2/install/setup.bash
export RMW_IMPLEMENTATION=rmw_cyclonedds_cpp
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/ros/humble/lib/x86_64-linux-gnu/
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/ros/humble/lib/

Any ideas what step I am missing? Thanks! Andy

[move_group-3] Loading 'move_group/ApplyPlanningSceneService'...
[move_group-3] Loading 'move_group/ClearOctomapService'...
[move_group-3] Loading 'move_group/MoveGroupCartesianPathService'...
[move_group-3] Loading 'move_group/MoveGroupExecuteTrajectoryAction'...
[move_group-3] Loading 'move_group/MoveGroupGetPlanningSceneService'...
[move_group-3] Loading 'move_group/MoveGroupKinematicsService'...
[move_group-3] Loading 'move_group/MoveGroupMoveAction'...
[move_group-3] Loading 'move_group/MoveGroupPlanService'...
[move_group-3] Loading 'move_group/MoveGroupQueryPlannersService'...
[move_group-3] Loading 'move_group/MoveGroupStateValidationService'...
[move_group-3] You can start planning now!
[spawner-5] [INFO] [1675967141.452893243] [spawner_joint_state_broadcaster]: Configured and activated joint_state_broadcaster
[spawner-7] [INFO] [1675967141.472921516] [spawner_panda_hand_controller]: Configured and activated panda_hand_controller
[spawner-6] [INFO] [1675967141.549995873] [spawner_panda_arm_controller]: Waiting for '/controller_manager' node to exist
[INFO] [spawner-5]: process has finished cleanly [pid 4958]
[INFO] [spawner-7]: process has finished cleanly [pid 4965]
[ros2_control_node-4] [INFO] [1675967141.759092619] [controller_manager]: Loading controller 'panda_arm_controller'
[ros2_control_node-4] [INFO] [1675967141.766369784] [joint_trajectory_controller.interpolation_methods]: No interpolation method parameter was given. Using the default, VARIABLE_DEGREE_SPLINE.
[spawner-6] [INFO] [1675967141.773474339] [spawner_panda_arm_controller]: Loaded panda_arm_controller
[ros2_control_node-4] [INFO] [1675967141.777138776] [controller_manager]: Configuring controller 'panda_arm_controller'
[ros2_control_node-4] [INFO] [1675967141.777227773] [panda_arm_controller]: No specific joint names are used for command interfaces. Using 'joints' parameter.
[ros2_control_node-4] [INFO] [1675967141.777245918] [panda_arm_controller]: Command interfaces are [position] and state interfaces are [position velocity].
[ros2_control_node-4] [INFO] [1675967141.777258471] [joint_trajectory_controller.interpolation_methods]: No interpolation method parameter was given. Using the default, VARIABLE_DEGREE_SPLINE.
[ros2_control_node-4] [INFO] [1675967141.777261246] [panda_arm_controller]: Using 'splines' interpolation method.
[ros2_control_node-4] [INFO] [1675967141.777848592] [panda_arm_controller]: Controller state will be published at 50.00 Hz.
[ros2_control_node-4] [INFO] [1675967141.778506029] [panda_arm_controller]: Action status changes will be monitored at 20.00 Hz.
[spawner-6] [INFO] [1675967141.804050679] [spawner_panda_arm_controller]: Configured and activated panda_arm_controller
[INFO] [spawner-6]: process has finished cleanly [pid 4961]
edit retag flag offensive close merge delete


Seems like you're mixing distributions. You've installed bits of Rolling and bits of Humble. Which space are you sourcing?

Unless you intentionally installed Rolling and have a specific need for Rolling, you may want to consider starting over and going straight Humble since it is released.

I know I haven't answered your question. My guess is you have RVIZ in one space and you're sourced in another. Log file analysis may help.

billy gravatar image billy  ( 2023-02-09 21:52:10 -0500 )edit

@billy - hmm thanks. I see what has happened. on the moveit page the link is "Install ROS 2 Humble" but when clicked on it is the rolling installation page.

andya gravatar image andya  ( 2023-02-10 09:59:42 -0500 )edit

@billy - I create a new VM and started from scratch. This time I was careful to only use humble. And... same result. Bummer. :(

andya gravatar image andya  ( 2023-02-10 13:08:46 -0500 )edit

You've tried ros2 run rviz2 rviz2 to verify RVIZ is good?

billy gravatar image billy  ( 2023-02-10 13:33:58 -0500 )edit

@billy - just tried and that command works. rviz opens.

andya gravatar image andya  ( 2023-02-10 13:44:31 -0500 )edit

see what happens if you open RVIZ manually and run the demo.

billy gravatar image billy  ( 2023-02-10 20:36:55 -0500 )edit

@andya what happens, if you open a terminal and type rviz2 directly?

Andromeda gravatar image Andromeda  ( 2023-02-11 10:06:05 -0500 )edit