Ask Your Question
0

rosws problem fuerte

asked 2012-08-11 16:09:28 -0600

Vishnu gravatar image

updated 2012-08-11 16:16:23 -0600

hi,

I have installed ROS successfully and also debian package for rosws. I have also setup a workspace for ROS with the command rosws init ~/fuerte_workspace /opt/ros/fuerte. But after using the command mkdir ~/fuerte_workspace/sandbox when I use rosws set ~/fuerte_workspace/sandbox and I get an error stating command requires a target workspace. Kindly help me.........

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-08-12 04:52:33 -0600

Lorenz gravatar image

You need to execute

source ~/fuerte_workspace/setup.sh

as stated at the tutorial, section 'Creating a new overlay'.

edit flag offensive delete link more

Comments

Even after executing this command, the $ROS_WORKSPACE is not set. I'm using Groovy under Ubuntu 12.10 32b. Any ideas why this happens?

Cristina gravatar imageCristina ( 2013-01-10 06:52:14 -0600 )edit
8

answered 2013-01-05 08:19:47 -0600

r0nald gravatar image

updated 2013-01-05 11:32:29 -0600

I had the same problem as described by the original post, but the ROS version is Groovy. Yes, I did run the setup.bash of the new workspace, but still I got the message:

ERROR in config: Command requires a target workspace.

I discovered, that I had to run rosws set inside the workspace directory, i.e.

rosws set ~/ros_workspace/sandbox

does not work, but

cd ~/ros_workspace/; rosws set sandbox

does work

edit flag offensive delete link more

Comments

Now I understand the reason for this behaviour. For some reason, ros_workspace/setup.bash did not set $ROS_WORKSPACE. Any ideas why?

r0nald gravatar imager0nald ( 2013-01-05 23:12:40 -0600 )edit

@r0nald Have you found out why $ROS_WORKSPACE was not set? I have the same problem (Groovy, Ubuntu 12.10 32b)

Cristina gravatar imageCristina ( 2013-01-10 06:50:16 -0600 )edit
1

Im not sure about rosbuild, but I wound out that in case of catkin build system, $ROS_WORKSPACE is not meant to be set by default and it is not necessary to set it unless you want command 'roscd' to take you to workspace from anywhere.

r0nald gravatar imager0nald ( 2013-01-12 05:27:45 -0600 )edit

@r0nald Thanks! It's good to know it's not necessary. I was afraid some tools would kick the bucket because they missed this var.

Cristina gravatar imageCristina ( 2013-01-12 22:22:35 -0600 )edit

i could not understand why going into the workspace directory to set it worked!, but sure it did.

searchrescue gravatar imagesearchrescue ( 2013-01-21 06:34:26 -0600 )edit
0

answered 2013-01-16 14:59:48 -0600

updated 2013-01-16 15:29:16 -0600

I have installed ros electric before, this time I am trying to install fuerte, encountered the same problem. I am not sure whether the same steps stated on

http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment http://www.ros.org/wiki/fuerte/Installation/Overlays http://www.ros.org/wiki/ROS/EnvironmentVariables

are the correct way or not... To me, using the command

rosws init ~/fuerte_workspace /opt/ros/fuerte

seems not work.

But after I tried the steps on this page http://www.ros.org/doc/api/rosinstall/html/rosws_tutorial.html solved. Need to make the directory first and run the rosws init inside the folder. It just overwrite the setup.sh and some other setting files.

However, during the operation I have installed several python packages, do not know whether it affects or not. One thing can be confirmed, that if you go through all the webpages listed above, rosws init will be done.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-11 16:09:28 -0600

Seen: 4,508 times

Last updated: Jan 16 '13