ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Moving in Rviz opposite to reality

asked 2023-01-23 09:14:19 -0500

Omar_Alkassas gravatar image

updated 2023-06-18 10:25:17 -0500

lucasw gravatar image

My mobile robot moves well in the gazebo and Rviz using teleop node. However, when I implement the real robot, the robot moves well, in reality, using teleop node while Rviz moved the opposite. It moves forward and backward well but turns right in reality while turning left in Rviz. Could you help me?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2023-01-23 23:10:56 -0500

billy gravatar image

There are a couple points that could be causing this issue and without more info it's difficult.

  • Incorrect static transform - a transform within your model may have the robot flipped along the X-Axis
  • Incorrect odom to base_link transform - calculations to built up the tranform may have either simply bad math or flipped the robot over(or something).
  • Incorrect odometry calcs - you don't describe the robot but if it is a differential drive then one motor is spinning forward and one backward and when calculating angle(rotation) maybe a minus sign got switched
  • You're viewing the RVIZ robot from the under side in RVIZ so it only looks like it's turning the wrong way - verify that the "Invert Z axis" in RVIZ is not checked.
  • You're viewing the real robot in a mirror and both the robot and RVIZ agree the TELOP is backwards.
edit flag offensive delete link more

Question Tools

Stats

Asked: 2023-01-23 09:14:19 -0500

Seen: 96 times

Last updated: Jan 23 '23