ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

ros2_control/asio : topics stops being received

asked 2023-01-18 05:28:55 -0500

Sam_Prt gravatar image

updated 2023-01-19 04:09:36 -0500

Hello,

I am having issues with a ros2_control on humble distro and ubuntu 22.04. I have a custom hardware system that communicates with the hardware with TCP/IP. I implemented the communication using asio, running in a thread. I am using a custom controller that basically is the forward_command_controller, without the realtime buffers. It subscribes to a single Float64MultiArray commands topic.

For some reason, the controllers subscriber stops receiving topics after a few messages. This results in the commands not being updated and sent to the hardware.

I suspect that using asio in a thread inside the ros2_control architecture might be causing problems but I am not certain.

Fell free to ask for more information. Any help would be appreciated !

EDIT: I tested with a minimal example with and without asio running in a thread and the result is the same. The topics stop being received after some short time. So the issue seems unrelated to asio.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-07-11 11:06:57 -0500

Sam_Prt gravatar image

This was a bug related to issue #656 in rmw_fastrtps. See the issue I opened on ros2_control/issues/923.

The bug is now fixed.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2023-01-18 05:28:55 -0500

Seen: 64 times

Last updated: Jul 11 '23