ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Package 'my_robot' not found: "package 'my_robot' not found, searching: ['/opt/ros/humble']"

asked 2023-01-15 08:26:51 -0500

pinkertinz gravatar image

I keep getting this error when trying to run ros2 launch my_robot urdf.launch.py

I have sourced my workspace. Commands I am running:

~/projects/ros_workspace$  source install/setup.bash

~/projects/ros_workspace$ ros2 launch my_robot urdf.launch.py


Package 'my_robot' not found: "package 'my_robot' not found, searching: ['/opt/ros/humble']"

My package built successfully. I have tried sourcing both my main install and workspace. Ive tried sourcing just one. Everything I seem to do doesnt change anything. I do not understand why its only searching /opt/ros/humble.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2023-01-15 08:45:16 -0500

pinkertinz gravatar image

It seems I had an error in my package.xml that was not showing on build but just when I looked through all the logs. Is it better to use cmake vs python to get better error generation on build?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2023-01-15 08:26:51 -0500

Seen: 574 times

Last updated: Jan 15 '23