No 'list_nodes' service found when listing components

asked 2023-01-11 06:18:07 -0500

Quiche gravatar image

Hello,

I am following the tutorial "Composing multiple nodes in a single process" at https://docs.ros.org/en/humble/Tutori... .
Running a container, talker and listner components seem to be fine. Talker & Listener Component are running

[INFO] [1673438897.342774400] [talker]: Publishing: 'Hello World: 947'
[INFO] [1673438897.343820300] [listener]: I heard: [Hello World: 947]
[INFO] [1673438898.331373000] [talker]: Publishing: 'Hello World: 948'
[INFO] [1673438898.332359600] [listener]: I heard: [Hello World: 948]
[INFO] [1673438899.336511500] [talker]: Publishing: 'Hello World: 949'
[INFO] [1673438899.337578700] [listener]: I heard: [Hello World: 949]
[INFO] [1673438900.332567400] [talker]: Publishing: 'Hello World: 950'
[INFO] [1673438900.333926600] [listener]: I heard: [Hello World: 950]
...

However,

ros2 component list

only shows

ComponentManager

with a message

No 'list_nodes' service found when listing components

ros2 component list result

c:\dev\ros2_ws>ros2 component list
/ComponentManager
No 'list_nodes' service response when listing components

c:\dev\ros2_ws>ros2 component load /ComponentManager composition composition::Talker
Loaded component 1 into '/ComponentManager' container node as '/talker'

c:\dev\ros2_ws>ros2 component load /ComponentManager composition composition::Listener
Loaded component 2 into '/ComponentManager' container node as '/listener'

c:\dev\ros2_ws>ros2 component list
/ComponentManager
No 'list_nodes' service response when listing components

c:\dev\ros2_ws>ros2 component list
/ComponentManager
No 'list_nodes' service found when listing components

c:\dev\ros2_ws>

where the result should be

/ComponentManager
1 /talker
2 /listener

as described in the tutorial page.

Is there something wrong with my environment? What does the message "No 'list_nodes' service found when listing components" mean?

Best Regards,
Quiche

edit retag flag offensive close merge delete