Navigation stack implementation - Robot does not follow the global planned trajectory

asked 2022-11-23 13:27:19 -0600

Polish98 gravatar image

I tried to implement the navigation stack on a ddr robot, the global planner generates a valid trajectory but the robot does not follow it. I tried to modify the parameters in the .yaml file, but nothing seems to work. I tried to use this github as a reference https://github.com/osrf/rosbook. These are the files: https://drive.google.com/drive/folder...

edit retag flag offensive close merge delete

Comments

If you are new to ros, you'd be better off first starting with a working example where all the files are provided for you. Many people use the turtlebot3 simulation: http://wiki.ros.org/turtlebot3_simula...

Make sure you follow the steps in the online manual.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2022-11-24 08:44:27 -0600 )edit

Yes, but I implemented the turtlebot3 simulation, but when i try to implement this simulation, the robot doesn't follow the trajectory, probably the problem is due to the tuning of parameters

Polish98 gravatar image Polish98  ( 2022-11-24 12:33:33 -0600 )edit

Are you trying to control a real robot, or do this in simulation? What sensors have you configured for localization e.g. wheel encoders or IMU or lidar? A local planner requires an estimate of the robot's current pose, which is done by measuring the movement of the robot.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2022-11-25 08:22:35 -0600 )edit