ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Can robot_localization be used with Noetic?

asked 2022-11-13 21:33:23 -0500

donguri gravatar image

updated 2023-06-18 09:45:05 -0500

lucasw gravatar image

Is robot_localization not available for ROS Noeic?

I git clone the "robot_localization" Package and tried to do a "catkin build", but it skips as follows.

[build] Warning: Skipping package `robot_localization` because it has an unsupported package build type: `ament_cmake`
[build] Note: Available build types:                                           
[build]  - `catkin`                                                            
[build]  - `cmake`

From my research, it seems that "ament_cmake" is a ROS2 specific build tool and cannot be used with Noetic. Please let me know if I am wrong.

Is there any way to use robot_localization with ROS Noetic?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-11-14 02:53:22 -0500

ravijoshi gravatar image

Can robot_localization be used with Noetic?

Yes.

Below are the two ways to install robot_localization in ROS Noetic:

  1. Install from Pre-built Binaries (Preferred): Please use the following command:

    $ sudo apt install ros-noetic-robot-localization
    
  2. Install from Source: To answer you completely, I tried this approach as well. Please see below:

    $ cd ros_ws/src
    $ git clone https://github.com/cra-ros-pkg/robot_localization.git --branch noetic-devel
    $ cd ros_ws/
    $ rosdep install --from-paths src --ignore-src -r -y
    $ catkin_make -DCMAKE_BUILD_TYPE=Release
    
edit flag offensive delete link more

Comments

Thank you for your prompt reply.

I can't try it right away, but I will certainly try it soon.

Thank you very much.

donguri gravatar image donguri  ( 2022-11-14 03:22:54 -0500 )edit

I can't try it right away, but I will certainly try it soon.

Does it work?

ravijoshi gravatar image ravijoshi  ( 2022-11-17 04:29:32 -0500 )edit

Dear ravijoshi.

Thank you for your patience. And thank you for your advice.

Thanks to you, everything went well.

The only thing I did was change $ catkin_make -DCMAKE_BUILD_TYPE=Release part to $ catkin build.

donguri gravatar image donguri  ( 2022-11-17 23:12:31 -0500 )edit

I am glad you made it work!

ravijoshi gravatar image ravijoshi  ( 2022-11-19 08:06:10 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2022-11-13 21:33:23 -0500

Seen: 421 times

Last updated: Nov 14 '22