Problem running GSCAM [closed]

asked 2012-08-07 23:11:41 -0500

fins gravatar image

Hi all, I managed to install the gscam package without problem. But when I ran the node via launch file, it produced this message:

Gstreamer Version: GStreamer 0.10.28
libv4lconvert: warning more framesizes then I can handle!
stream is PAUSED.

But, if I ran the image_view node to see the video, it still worked. I also tried to reduce the framesize, but the message still appeared. Do you have any idea why this happened?

I'm running on Intel Atom 1.6Ghz with Ubuntu 10.04 and using Logitech C905 for the camera. Below are my settings in the launch file:

<node name="gscam" pkg="gscam" type="gscam" output="screen" >
<env name="GSCAM_CONFIG" value="v4l2src device=/dev/video1 !
video/x-raw-rgb, width=640,height=480,framerate=20/1 ! ffmpegcolorspace !
identity name=ros"/>

Thanks before.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-04-05 20:39:01.510798