ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Navigation stack error while launching

asked 2022-10-18 05:06:10 -0500

Kostas Tzias gravatar image

In my costmap_common_param.yaml file i've placed these two lines :

observation_sources: laser_scan_sensor
laser_scan_sensor: {sensor_frame:base_scan, data_type: LaserScan, topic: scan, marking: true, clearing: true}

When i am launching my nav_pkg i get this error :

load_parameters: unable to set parameters (last param was [/move_base/TrajectoryPlannerROS/holonomic_robot=False]): cannot marshal None unless allow_none is enabled

I've been searching for a while and i found a comment which says that this error means one of the parameters is null (undefined or an empty string). It also says to add the following line when roslaunching the nav_pkg :

--dump-params

Indeed when i did it i found this :

/move_base/global_costmap/laser_scan_sensor/sensor_frame:base_scan: null

But i have no ideas why is this happening and also i don't know how to fix it. Any suggestions ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-10-18 06:46:09 -0500

ravijoshi gravatar image

Can you please try again after adding a space between sensor_frame: and base_scan as shown below:

laser_scan_sensor: {sensor_frame: base_scan, data_type: LaserScan, topic: scan, marking: true, clearing: true}

Please report if the problem persists.

edit flag offensive delete link more

Comments

Yeah that worked i guess it is white space sensitive

Kostas Tzias gravatar image Kostas Tzias  ( 2022-10-19 05:34:10 -0500 )edit

Well, it is a YAML file, so you must use space. Anyway, I am glad that it worked. You may upvote the answer by clicking on the ^ icon located on the left side of the answer.

ravijoshi gravatar image ravijoshi  ( 2022-10-19 05:48:22 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2022-10-18 05:06:10 -0500

Seen: 70 times

Last updated: Oct 18 '22