Ask Your Question
0

Hector_Slam tutorial problem (Map is not created) [closed]

asked 2012-08-07 01:34:35 -0500

Tirgo gravatar image

Hi all

I started to work with hector slam. My system is ubuntu 11.10 and fuerte full.

My problem is if i try to run the tutorial (described here http://www.ros.org/wiki/hector_slam/Tutorials/MappingUsingLoggedData) Everything seems to work nice in rviz. I get no errors or warnings nothing, but the map is not created. Even if i look at the laserscan in rviz i can see your walk through the labyrinth. I installed the correct version of hector_slam for fuerte. I also tried this: http://answers.ros.org/question/35588/hector-slam-visualization-error/

I also looked at the /map topic before and after i start the rosbag file. It seems like nothing changes. I can only see hundreds of "-1" But okay i have no idea what should be there. ;)

Hoping for some help i can't find more solutions here

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Tirgo
close date 2015-05-11 02:45:17.867559

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-08-07 02:33:22 -0500

allenh1 gravatar image

You'll need to be more specific in saying that the map is not created. Because you have no warnings from Hector Mapping, I assume everything is working. The inability to see the map in RVIZ is likely the frame ID. You find this inside RVIZ.

But, let's see if the map is being created. Try to save the map with this command:

rosrun map_server map_saver -f ~/test

If all goes well, the map will be saved in your home folder. Two files will be created: test.pgm and test.yaml. If the image in test.pgm is blank, then there is some problem with the hector side. If you are still having troubles, could you please screenshot RVIZ and edit your question? That would be very helpful in resolving your issue. Terminal output is also nice.

The "-1" you see is neither occupied nor open (has yet to be written to). This is just blank, uncharted territory. Not a big deal.

edit flag offensive delete link more

Comments

Hi thx for your response I meant that i got no warnings/errors in Rviz (like no messages or so) and Hector mapping. But there is no map building in rviz. I will try to save the map in a couple of mins and to make a screenshot.

Tirgo gravatar imageTirgo ( 2012-08-07 02:46:43 -0500 )edit

so i tried it on an other pc and its working there perfectly. I have no clue why its not working on my netbook. I will try to download and build it again later.

Tirgo gravatar imageTirgo ( 2012-08-07 03:48:09 -0500 )edit

so i tried it on an other pc and its working there perfectly. i Have no clue why its not working on my netbook. I will try to download and build it again later.

Tirgo gravatar imageTirgo ( 2012-08-07 03:48:11 -0500 )edit

so i tried it on an other pc and its working there perfectly. i Have no clue why its not working on my netbook. I will try to download and build it again later.

Tirgo gravatar imageTirgo ( 2012-08-07 03:48:14 -0500 )edit

@allenh1 I have the same problem ,when i have saved the map two files have been created: test.pgm and test.yaml,but the image in test.pgm is blank how can i fix this error ?

marwa gravatar imagemarwa ( 2013-02-03 23:45:00 -0500 )edit

If the image is blank, then the map has no data.

allenh1 gravatar imageallenh1 ( 2013-02-06 04:13:22 -0500 )edit
1

Hey,

I have the same problem, I can see the map when I print it; however can't see anything on RViz. Why can't i see it on the RViz?

ebozgul gravatar imageebozgul ( 2013-06-14 00:54:26 -0500 )edit

I also experienced the same problem. When I try to save the map, it said: [rospack] Error: package 'map_server' not found. Can anyone give me some advice please? Thanks.

StevenJiang gravatar imageStevenJiang ( 2015-04-25 06:50:36 -0500 )edit

Question Tools

Stats

Asked: 2012-08-07 01:34:35 -0500

Seen: 1,365 times

Last updated: Aug 07 '12