ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

CMake Error at vision_visp/visp_bridge/CMakeLists.txt:16 (find_package):

asked 2022-10-04 12:03:24 -0500

akumar3.1428 gravatar image

updated 2023-06-18 09:46:14 -0500

lucasw gravatar image

Hello, I tried the following command to install vision_visp

git clone -b kinetic-devel  https://github.com/lagadic/vision_visp.git

However, I am not sure that why I am getting the following error:

CMake Error at vision_visp/visp_bridge/CMakeLists.txt:16 (find_package):
  By not providing "FindVISP.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "VISP", but
  CMake did not find one.

  Could not find a package configuration file provided by "VISP" with any of
  the following names:

        VISPConfig.cmake
    visp-config.cmake

  Add the installation prefix of "VISP" to CMAKE_PREFIX_PATH or set
  "VISP_DIR" to a directory containing one of the above files.  If "VISP"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!
See also "/home/akumar/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/akumar/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

Can anyone help me please to solve this error? I am using ROS Noetic in Ubuntu 20.04.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-10-05 04:30:39 -0500

ravijoshi gravatar image

There are following two ways to install vision_visp:

  1. Install using apt: I prefer this option as it takes care of installing dependencies and takes less time. Please use the following command:

    $ sudo apt-get install ros-noetic-vision-visp
    
  2. Install from source: This definitely takes a considerable amount of time to compile. Furthermore, all the dependencies must be installed before compilation. Please see below for more details:

    ravi@dell:~/ros_ws$ source /opt/ros/noetic/setup.bash
    
    ravi@dell:~/ros_ws$ git clone --branch noetic git@github.com:lagadic/vision_visp.git
    
    ravi@dell:~/ros_ws$ sudo rosdep init
    
    ravi@dell:~/ros_ws$ rosdep update
    
    ravi@dell:~/ros_ws$ rosdep install --from-paths src --ignore-src --rosdistro noetic
    executing command [sudo -H apt-get install libdmtx-dev]
    executing command [sudo -H apt-get install ros-noetic-visp]
    executing command [sudo -H apt-get install libzbar-dev]
    
    ravi@dell:~/ros_ws$ catkin_make -DCMAKE_BUILD_TYPE=Release
    

    You can notice that we have quite a few dependencies to build this package!

Finally, the above steps are taken from the wiki page and confirmed on my machine (ROS Noetic in Ubuntu 20.04)

edit flag offensive delete link more

Comments

Thank you for your response, I will try to install everything using apt command as it is recommended.

akumar3.1428 gravatar image akumar3.1428  ( 2022-10-05 20:14:12 -0500 )edit

Please, let me know if the problem persists. Furthermore, please upvote and mark this answer as correct in order to tag your question as answered.

ravijoshi gravatar image ravijoshi  ( 2022-10-05 20:28:59 -0500 )edit

Thank you, the following error has been, resolved.

akumar3.1428 gravatar image akumar3.1428  ( 2022-10-05 20:30:05 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2022-10-04 12:03:24 -0500

Seen: 476 times

Last updated: Oct 05 '22