(realsense2_camera) nodelet manager has died

asked 2022-10-03 14:00:23 -0500

akumar3.1428 gravatar image

updated 2022-10-04 05:00:33 -0500

ravijoshi gravatar image

I want to use RealSense camera for my robot. So I tried using ROS wrapper for RealSense SDK following the tutorial. Later. I tried running the testing command roslaunch realsense2_camera rs_camera.launch. Both method 1 and 2, are showing the error. I know there is something wrong with the ddynamic_reconfigure file, I already tried removing it from catkin/src but still getting the following error:

[camera/realsense2_camera_manager-2] process has died [pid 6335, exit code 127, cmd /opt/ros/noetic/lib/nodelet/nodelet manager __name:=realsense2_camera_manager __log:=/home/akumar/.ros/log/e5370276-434c-11ed-9d35-43b6dbe9278d/camera-realsense2_camera_manager-2.log].
    log file: /home/akumar/.ros/log/e5370276-434c-11ed-9d35-43b6dbe9278d/camera-realsense2_camera_manager-2*.log

I am using ROS Noetic on Ubuntu 20.04.

edit retag flag offensive close merge delete


It seems like you are missing part of your question, can you edit it?

ljaniec gravatar image ljaniec  ( 2022-10-03 19:06:14 -0500 )edit

I have edited the above question please guide me through this.

akumar3.1428 gravatar image akumar3.1428  ( 2022-10-03 19:13:41 -0500 )edit
  1. The realsense2_camera package works smoothly. It is probably due to incomplete installation or incorrect dependencies; For example, the ddynamic_reconfigure package must be installed if you compile it from the source. On the other hand, I prefer quick installation via apt.
  2. Next, check if the realsense-viewer command works fine in the terminal. You should be able to see the images from your camera.
  3. You should also confirm that your realsense2_camera package is using a supported librealsense package. Please check documentation for more info.
  4. If the above steps don't help, I recommend opening an issue on the realsense-ros/issues page. Their support team is really quick!
ravijoshi gravatar image ravijoshi  ( 2022-10-04 05:09:03 -0500 )edit

Thank you for your response, I removed it and then installed using apt and it is working now.

akumar3.1428 gravatar image akumar3.1428  ( 2022-10-04 11:58:28 -0500 )edit

Glad you made it work!

ravijoshi gravatar image ravijoshi  ( 2022-10-04 20:49:20 -0500 )edit