ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Pkg not found error. Is SetuptoolsDeprecationWarning the cause?

asked 2022-09-28 13:17:58 -0500

akshata101 gravatar image

updated 2022-09-30 06:38:56 -0500

ravijoshi gravatar image

When I try to build my workspace I get the following error -

akshata@akshata:~/ros2_humble$ colcon build

Starting >>> px4_msgs
Starting >>> py_pubsub
--- stderr: py_pubsub                                                            
/usr/local/lib/python3.10/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
---
Finished <<< py_pubsub [1.60s]
Finished <<< px4_msgs [9.03s]                     

Summary: 2 packages finished [9.22s]
  1 package had stderr output: py_pubsub

I've read that it's a known issue and for some people downgrading worked.

None of it worked for me. Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-09-30 10:05:42 -0500

yashi gravatar image

It shouldn't be. You always get that warning with the current colcon. See https://github.com/colcon/colcon-core....

For py_pubsub error, analyze its log.

cat log/latest/py_pubsub/stdout_stderr.log

This is what I get after ros2 pkg create --build-type ament_python py_pubsub

cd humble-ws
ros2 pkg create --build-type ament_python py_pubsub
colcon build --symlink-install --merge-install --packages-up-to py_pubsub
 :
Summary: 5 packages finished [13.7s]
  5 packages had stderr output: ament_copyright ament_flake8 ament_lint ament_pep257 py_pubsub
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2022-09-28 13:17:58 -0500

Seen: 452 times

Last updated: Sep 30 '22