Fusing ARTags poses with robot_localization

asked 2022-09-06 10:20:52 -0500

asser19 gravatar image

Hello.

I'm on ROS Noetic on 20.04 LTS.

I'll begin listing my problems and how I think about the solution and how it doesn't work.

I've been trying to make full 3D navigation system, for a mobile robot that's in a big open area with tags in certain locations. I used rtabmap package for mapping and it takes the odom frame published by robot_localization and publishes the map->odom transform (according to the tf tree) robot_localization is used to fuse some of the sensors (wheel odom velocities, IMU orientations, and a bit of vo velocities as well) It's been working fine. here's my ekf_3d.yaml config file.

frequency: 30
sensor_timeout: 0.2
two_d_mode: false
transform_time_offset: 0.0
transform_timeout: 0.0
print_diagnostics: true
debug: false
publish_tf: true
publish_acceleration: false

map_frame: map
odom_frame: odom
base_link_frame: base_footprint
world_frame: odom

# x, y, z
# roll, pitch, yaw
# vx, vy, vz
# vroll, vpitch, vyaw
# ax, ay, az.

odom0: /wheel_odom_with_covariance
odom0_config: [false, false, false,
                false, false, false,
                true,  false, false,
                false, false, true,
                false, false, false]
odom0_differential: false
odom0_queue_size: 3
#odom0_rejection_threshold: 15
odom0_nodelay: false

odom1: /zed2/rgbd_odom
odom1_config: [false, false, false,
                false, false, false,
                false,  true, true,
                false, false, false,
                false, false, false]
odom1_differential: false
odom1_relative: false
odom1_queue_size: 3
#odom1_rejection_threshold: 15
odom1_nodelay: false

pose0: /pose_corrector
pose0_config: [true, true, false,
                false, false, false,
                false,  false, false,
                false, false, false,
                false, false, false]
pose0_differential: false
pose0_queue_size: 3
pose0_nodelay: false

imu0: imu/data
imu0_config: [false, false, false,
              true,  true,  false,
              false, false, false,
              true,  true,  true,
              true,  false, false]
imu0_nodelay: false
imu0_differential: false
imu0_relative: true
imu0_queue_size: 5
imu0_remove_gravitational_acceleration: true

process_noise_covariance: [0.05, 0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0.05, 0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0.06, 0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0.03, 0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0.03, 0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0.06, 0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0.5,   0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0.025, 0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0.04, 0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0.01, 0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0.01, 0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0.4,  0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0.01, 0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0.01, 0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0 ...
(more)
edit retag flag offensive close merge delete

Comments

"Also I don't know how to stop rtabmap from publishing map->odom" -> set publish_tf:=false parameter of rtabmap node.

matlabbe gravatar image matlabbe  ( 2022-10-23 21:09:29 -0500 )edit