Rtabmap providing very low keypoints and missing matches

asked 2022-08-31 12:24:59 -0600

marpeja gravatar image

Hi!

I am asking this question here as in the Rtabmap forum nobody answers, and I know there are lot of people in this one that work with Rtabmap as well.

I have created a cave using Blender and exported it as a collada file. Rtabmap does the mapping perfectly, but then, it isn't able to localize the robot on it.

I loaded the database viewer and realized that the number of keypoints is very very low. What's more, even being in the same position, there are lots of keypoints that don't match, so Rtabmap isn't able to find a loop closure and localize the robot.

image description

Any ideas on how can I change this behavior?

edit retag flag offensive close merge delete

Comments

Add more texture to your simulated world. I would say add more random texture, to avoid repetitive texture that could cause wrong loop closures.

matlabbe gravatar image matlabbe  ( 2022-10-23 21:48:55 -0600 )edit