Ask Your Question
0

Rosdep Permission Error: [Error 13]

asked 2022-06-29 01:35:16 -0500

TRo gravatar image

updated 2022-06-29 05:11:52 -0500

gvdhoorn gravatar image

Hi. I'm installing Moveit2 (ROS Foxy), and faced this error while following the installation guides on https://moveit.picknik.ai/foxy/doc/ge...

I'm struggling so much with installing Moveit2 for whole day, and I really hope I could get some help....

rosdep version: 0.22.1

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/rosdep2/main.py", line 146, in rosdep_main
    exit_code = _rosdep_main(args)
  File "/usr/lib/python3/dist-packages/rosdep2/main.py", line 446, in _rosdep_main
    return _package_args_handler(command, parser, options, args)
  File "/usr/lib/python3/dist-packages/rosdep2/main.py", line 542, in _package_args_handler
    lookup = _get_default_RosdepLookup(options)
  File "/usr/lib/python3/dist-packages/rosdep2/main.py", line 134, in _get_default_RosdepLookup
    sources_loader = SourcesListLoader.create_default(sources_cache_dir=options.sources_cache_dir,
  File "/usr/lib/python3/dist-packages/rosdep2/sources_list.py", line 601, in create_default
    sources = load_cached_sources_list(sources_cache_dir=sources_cache_dir, verbose=verbose)
  File "/usr/lib/python3/dist-packages/rosdep2/sources_list.py", line 563, in load_cached_sources_list
    return parse_sources_data(cache_data, origin=cache_index, model=model)
  File "/usr/lib/python3/dist-packages/rosdep2/sources_list.py", line 380, in parse_sources_data
    sources.append(model(type_, url, tags, origin=origin))
  File "/usr/lib/python3/dist-packages/rosdep2/sources_list.py", line 194, in create_model
    with open(pickle_filepath, 'rb') as f:
PermissionError: [Errno 13] Permission denied: '/home/tro/.ros/rosdep/sources.cache/7cfbeed211a3f9a6507c86cebaeedb3e3c4387f8.pickle'

I tried the solutionsudo rosdep fix-permissionsposted on https://answers.ros.org/question/1755..., but it still doesn't solve the problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-06-29 02:20:19 -0500

ijnek gravatar image

updated 2022-06-29 02:20:37 -0500

Although I don't know what the source of the issue is, you could work around it by manually adding read/write permissions for your user to all files in the /home/tro/.ros/rosdep/sources.cache/ directory, by running:

chmod u+rw ~/.ros/rosdep/sources.cache/*

and re-run the command that caused the error.

edit flag offensive delete link more

Comments

I don't know why but it worked all of a sudden... But I faced another problem, which I'm gonna post it in another page. Thanks for your reply anyway :)

TRo gravatar image TRo  ( 2022-06-29 03:20:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2022-06-29 01:35:16 -0500

Seen: 20 times

Last updated: Jun 29