Ask Your Question
0

updaterate in libgazebo_ros_imu [closed]

asked 2012-07-31 21:42:25 -0500

g.aterido gravatar image

Hi

I'm trying to simulate an IMU with the plugin libgazebo_ros_imu, but I have one problem. I've defined in my .urdf the following code:

  <gazebo>
    <controller:gazebo_ros_imu name="imu_controller" plugin="libgazebo_ros_imu.so">
      <alwaysOn>true</alwaysOn>
      <updateRate>50.0</updateRate>
      <bodyName>imu_link</bodyName>
      <topicName>odom/imu</topicName>
      <gaussianNoise>2.89e-08</gaussianNoise>
      <xyzOffsets>0 0 0</xyzOffsets>
      <rpyOffsets>0 0 0</rpyOffsets>
      <interface:position name="imu_position"/>
    </controller:gazebo_ros_imu>
  </gazebo>

I set the frequency to 50 Hz, but when I do rostopic hz I get that the node is publishing at 1000 Hz (more or less). I've checked the plugin source code and I've seen that it gets all the params except the updateRate, so I think that thats the reason why I can't set the frequency I want.

I'm I right? And then, what can I do for changing the frequency?

I'm using Fuerte in Ubuntu 12.04

Thanks in advance. Regards!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by g.aterido
close date 2013-02-12 00:06:24

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-16 23:29:52 -0500

g.aterido gravatar image

updated 2012-10-21 21:04:47 -0500

Well, the solution was use other plugin for the IMU. The IMU of hector_gazebo_plugins does not have this problem and works perfectly ;)

edit flag offensive delete link more

Comments

Could you please share where did you find the source code of this libgazebo_ros plugin? I am facing the same problem but with the libgazebo_ros_projector. I suspect that inside it there is no call to some sdf tags such as the <alwayson>.

hbaqueiro gravatar image hbaqueiro  ( 2018-11-21 10:22:36 -0500 )edit

Question Tools

Stats

Asked: 2012-07-31 21:42:25 -0500

Seen: 893 times

Last updated: Oct 21 '12