Ask Your Question
4

ROS Humble Ubuntu 22.04 Apt Install Issue

asked 2022-06-23 10:28:27 -0500

jgoppert gravatar image

updated 2022-06-23 11:03:25 -0500

gvdhoorn gravatar image

After following: https://docs.ros.org/en/humble/Instal... and doing a system upgrade, I am unable to install ros-humble-desktop-full or ros-rolling-desktop-full (see https://github.com/ros2/ros2/issues/1272):

$ sudo apt install ros-humble-desktop
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
       Depends: libsystemd0 but it is not installable
 bsdutils : PreDepends: libsystemd0 but it is not installable
 dconf-gsettings-backend : Depends: dconf-service (< 0.40.0-3.1~)
                           Depends: dconf-service (>= 0.40.0-3)
 init : PreDepends: systemd-sysv
 libcolord2 : Depends: libudev1 (>= 196) but it is not installable
 libdbus-1-3 : Depends: libsystemd0 but it is not installable
               Recommends: dbus
 libgudev-1.0-0 : Depends: libudev1 (>= 199) but it is not installable
 libhwloc15 : Depends: libudev1 (>= 183) but it is not installable
 libignition-cmake2-dev : Depends: cmake
 libinput10 : Depends: libudev1 (>= 183) but it is not installable
              Depends: libinput-bin (>= 1.20.0-1ubuntu0.1)
 libopenmpi-dev : Depends: openmpi-bin (>= 3.0.0-1)
                  Recommends: libcoarrays-openmpi-dev but it is not going to be installed
 libopenni2-0 : Depends: libudev1 (>= 183) but it is not installable
 libpulse0 : Depends: libsystemd0 but it is not installable
 libqt5gui5 : Depends: libudev1 (>= 183) but it is not installable
 libudev-dev : Depends: libudev1 (= 249.11-0ubuntu3) but it is not installable
 libusb-1.0-0 : Depends: libudev1 (>= 183) but it is not installable
 mpi-default-bin : Depends: openmpi-bin
 ros-humble-ament-cmake : Depends: cmake
 ros-humble-ament-cmake-core : Depends: cmake
 ros-humble-foonathan-memory-vendor : Depends: cmake
 shim-signed : Depends: grub-efi-amd64-signed but it is not going to be installed or
                        grub-efi-arm64-signed but it is not installable
               Depends: grub2-common (>= 2.04-1ubuntu24)
 util-linux : PreDepends: libsystemd0 but it is not installable
              PreDepends: libudev1 (>= 183) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
edit retag flag offensive close merge delete

Comments

I'm getting the same error on a brand new Jammy install.

Morris gravatar image Morris  ( 2022-06-24 16:51:37 -0500 )edit

I have the same issues with a newly installed jammy

prawat gravatar image prawat  ( 2022-06-26 08:10:36 -0500 )edit

This is being tracked in ros2/ros2#1287.

As this is a known issue, I suggest (future) readers to refer to that issue, instead of posting here.

gvdhoorn gravatar image gvdhoorn  ( 2022-06-27 02:52:37 -0500 )edit

After dist-upgrade

$ sudo apt-cache policy libudev1 libudev1: Installed: 249.11-0ubuntu3.3 Candidate: 249.11-0ubuntu3.3 Version table: *249.11-0ubuntu3.3 500 500 http://us.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages 100 /var/lib/dpkg/status 249.11-0ubuntu3 500 500 http://us.archive.ubuntu.com/ubuntu jammy/main amd64 Packages

prawat gravatar image prawat  ( 2022-07-01 11:08:11 -0500 )edit
1

install ros-humble-desktop now works without problems.

prawat gravatar image prawat  ( 2022-07-03 11:39:00 -0500 )edit

@prawat Can you please elaborate? I am still experiencing this problem

omers gravatar image omers  ( 2022-07-05 07:10:02 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2022-06-26 10:40:01 -0500

LeonidasEng gravatar image

Hi I had this same issue for ROS Humble Ubuntu 22.04. I did some digging and managed to get a solution, that worked for me. See below:

My dependencies

$ sudo apt install ros-humble-desktop       
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

    The following information may help to resolve the situation:
The following packages have unmet dependencies.
apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
           Depends: libsystemd0 but it is not installable
     bsdutils : PreDepends: libsystemd0 but it is not installable
     dconf-gsettings-backend : Depends: dconf-service (< 0.40.0-3.1~)
                               Depends: dconf-service (>= 0.40.0-3)
     init : PreDepends: systemd-sysv
     libcolord2 : Depends: libudev1 (>= 196) but it is not installable
     libdbus-1-3 : Depends: libsystemd0 but it is not installable
                   Recommends: dbus
     libgudev-1.0-0 : Depends: libudev1 (>= 199) but it is not installable
     libhwloc15 : Depends: libudev1 (>= 183) but it is not installable
     libignition-cmake2-dev : Depends: cmake
     libinput10 : Depends: libudev1 (>= 183) but it is not installable
                  Depends: libinput-bin (>= 1.20.0-1ubuntu0.1)
     libopenmpi-dev : Depends: openmpi-bin (>= 3.0.0-1)
                      Recommends: libcoarrays-openmpi-dev but it is not going to be installed
     libopenni2-0 : Depends: libudev1 (>= 183) but it is not installable
     libpulse0 : Depends: libsystemd0 but it is not installable
     libqt5gui5 : Depends: libudev1 (>= 183) but it is not installable
     libudev-dev : Depends: libudev1 (= 249.11-0ubuntu3) but it is not installable
     libusb-1.0-0 : Depends: libudev1 (>= 183) but it is not installable
     mpi-default-bin : Depends: openmpi-bin
     ros-humble-ament-cmake : Depends: cmake
     ros-humble-ament-cmake-core : Depends: cmake
    ros-humble-foonathan-memory-vendor : Depends: cmake
    shim-signed : Depends: grub-efi-amd64-signed but it is not going to be installed or
                            grub-efi-arm64-signed but it is not installable
                   Depends: grub2-common (>= 2.04-1ubuntu24)
     util-linux : PreDepends: libsystemd0 but it is not installable
                  PreDepends: libudev1 (>= 183) but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Reinstalled dependencies by sending stdout to file:

$ sudo apt install ros-humble-desktop &> ROS-install-ERR.txt

I tried reinstalling MY dependencies and missing programs that were listed in ROS-install-ERR.txt

$ sudo apt install --reinstall libapt-pkg6.0 libsystemd0 dconf-service systemd-sysv libudev1 dbus libinput-bin libcoarrays-openmpi-dev grub-efi-amd64-signed grub2-common
$ sudo apt-get install cmake

Reason for Error Some dependencies are not installed, and the previously installed versions of the dependencies are not correct, some require downgrade, and some require upgrade.

Solution Install aptitude:

$ sudo apt-get install aptitude

1.

$ sudo aptitude install ros-humble-desktop

You should see a list of dependencies and a proposed action:

The following packages have unmet dependencies:

 ros-humble-desktop : Depends: ros-humble-action-tutorials-cpp but it is not installable
      <Dependencies listed>

The following actions will resolve these dependencies:

     Keep the following packages at their current version:

         ros-humble-desktop [Not Installed]

2. The first prompt reminds us that there are a lot of things that are not installed let us choose No:

Type: N

3. The second prompt may ask us ... (more)

edit flag offensive delete link more

Comments

That works for me. Thanks

kolodm gravatar image kolodm  ( 2022-07-07 12:53:58 -0500 )edit
0

answered 2022-07-05 07:39:15 -0500

prawat gravatar image

I did sudo dist-upgrade and sudo apt-cahce policy libudev1 showed libudev1: Installed: 249.11-0ubuntu3.3 Candidate: 249.11-0ubuntu3.3 Version table: *249.11-0ubuntu3.3 500 500 http://us.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages 100 /var/lib/dpkg/status 249.11-0ubuntu3 500 500 http://us.archive.ubuntu.com/ubuntu jammy/main amd64 Packages

sudo install ros-humble-desktop

now works.

edit flag offensive delete link more
0

answered 2022-06-23 14:10:10 -0500

rshanor gravatar image

I am seeing something similar with ros base.

sudo apt install ros-humble-ros-base
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
       Depends: libsystemd0 but it is not installable
 bsdutils : PreDepends: libsystemd0 but it is not installable
 init : PreDepends: systemd-sysv
 ros-humble-ament-cmake : Depends: cmake
 ros-humble-ament-cmake-core : Depends: cmake
 shim-signed : Depends: grub-efi-amd64-signed but it is not going to be installed or
                        grub-efi-arm64-signed but it is not installable
               Depends: grub2-common (>= 2.04-1ubuntu24)
 util-linux : PreDepends: libsystemd0 but it is not installable
              PreDepends: libudev1 (>= 183) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
edit flag offensive delete link more
0

answered 2022-06-23 11:38:57 -0500

EdSeymore gravatar image

updated 2022-06-24 08:03:53 -0500

Q. Does sudo apt upgrade now also fail with The following packages have unmet dependencies: libignition-plugin-dev : Depends: libignition-plugin (= 1.2.1+osrf-1~jammy) but 1.2.1-1~focal is installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Added 06/24/2022: In my case. I had a working Ubuntu 20.04 image with a working ROS2 Foxy and Galatic. The Humble binary install required Ubuntu 22.04, so I ran Ubuntu 20.04 to 22.04 upgrade. Did apt update and apt upgrade and then sudo apt install ros-humble-desktop which failed.

edit flag offensive delete link more

Comments

In my case no, sudo apt upgrade is fine.

rshanor gravatar image rshanor  ( 2022-06-23 14:10:59 -0500 )edit

Sudo apt upgrade doesn't fail. apt --fix broken returns without any changes. I am able to install any dependency like libignition-plugin, but I am unable to install any ros-humble-... package without this issue. For now I just built ros2 from source and it is fine.

jgoppert gravatar image jgoppert  ( 2022-06-23 14:27:58 -0500 )edit

no unmet dependencies when apt upgrade. Followed the binary packages Debian packages installation steps. When install ros-humble-desktop there are unmet dependencies, $ sudo apt install ros-humble-desktop Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed Depends: libsystemd0 but it is not installable bsdutils : PreDepends: libsystemd0 but it is not installable dconf-gsettings-backend : Depends: dconf-service (< 0.40.0-3.1~) Depends: dconf-service (>= 0.40.0-3) init : PreDepends: s

prawat gravatar image prawat  ( 2022-06-26 07:55:55 -0500 )edit

Can you do a dist-upgrade? What does apt-cache policy libudev1 show?

tfoote gravatar image tfoote  ( 2022-06-30 17:55:08 -0500 )edit

sudo apt-get dist-upgrade [sudo] password for ed: Reading package lists... Done Building dependency tree... Done Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libignition-plugin-dev : Depends: libignition-plugin (= 1.2.1+osrf-1~jammy) but 1.2.1-1~focal is installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

EdSeymore gravatar image EdSeymore  ( 2022-07-22 09:37:59 -0500 )edit

apt-cache policy libudev1 libudev1: Installed: 249.11-0ubuntu3.3 Candidate: 249.11-0ubuntu3.4 Version table: 249.11-0ubuntu3.4 500 500 http://us.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages *249.11-0ubuntu3.3 100 100 /var/lib/dpkg/status 249.11-0ubuntu3 500 500 http://us.archive.ubuntu.com/ubuntu jammy/main amd64 Packages

EdSeymore gravatar image EdSeymore  ( 2022-07-22 09:39:44 -0500 )edit

sudo apt --fix-broken install libignition-plugin-dev Reading package lists... Done Building dependency tree... Done Reading state information... Done libignition-plugin-dev is already the newest version (1.2.1+osrf-1~jammy). libignition-plugin-dev set to manually installed. You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libignition-plugin-dev : Depends: libignition-plugin (= 1.2.1+osrf-1~jammy) but 1.2.1-1~focal is to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

EdSeymore gravatar image EdSeymore  ( 2022-07-22 11:34:00 -0500 )edit
EdSeymore gravatar image EdSeymore  ( 2022-07-30 12:02:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2022-06-23 10:28:27 -0500

Seen: 566 times

Last updated: Jul 05