ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Real robot UR3e is not moving with moveit

asked 2022-06-23 05:58:57 -0600

AlexandrosNic gravatar image

updated 2022-06-23 06:50:21 -0600

I am connected to a UR3e over the network, working on ROS2 Foxy, on Ubuntu 20.04, via docker.

  • I set up the right host IP on the robot and robot’s IP in the launch file
  • I installed the external control urcap
  • I tried with both enable/disable remote control, and with both local/remote control on teach pendant
  • I tried calibrating the robot (with ur_calibration)

Then I run

ros2 launch ur_bringup ur_type:=ur3e robot_ip:= launch_rviz:=false reverse_ip:= limited:=true

on one terminal and

ros2 launch ur_bringup ur_type:=ur3e robot_ip:= launch_rviz:=true reverse_ip:=

on another terminal.

After that, I run the program on the teach pendant of the robot with the external control (with the correct IP).

Rviz starts with the robot at the right position. I plan and execute a random trajectory.

I get this outputs in terminal 1: Received new action goal Accepted new action goal Goal reached, success! and these on terminal 2: Completed trajectory execution with status SUCCEEDED Solution was found and executed. Plan and Execute request complete! However the real robot does not move. There is no error in the terminals.

Also I was wondering whether warehouse_ros_mongo is really necessary and what does it exactly do?

Any clue what could be the problem here?

PS: It could be a docker issue?

Thank you in advance

edit retag flag offensive close merge delete


fexner gravatar image fexner  ( 2022-06-27 07:57:57 -0600 )edit

It is indeed. Just wanted to reach different members of answers.ros, the UR forum, and github repo, without necessarily be a burden to you fexner. But thank you anw for your replies :)

AlexandrosNic gravatar image AlexandrosNic  ( 2022-06-28 05:42:23 -0600 )edit

Just wanted to reach different members of answers.ros, the UR forum, and github repo

this is actually called cross-posting, and isn't a very nice thing to do to/in online communities, even if your intentions were good.

gvdhoorn gravatar image gvdhoorn  ( 2022-06-29 05:21:00 -0600 )edit

good to know! thanks anyway!

AlexandrosNic gravatar image AlexandrosNic  ( 2022-06-29 06:06:08 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2022-06-28 05:47:52 -0600

AlexandrosNic gravatar image

updated 2022-06-28 05:49:51 -0600

The solution was posted here by @fexner. It seems that the reverse_ip is not yet working for ROS2 drivers, which prompts the UR to use the directly recognized port of the host machine, which in my case is the docker port. However, the host machine port (not the docker) port is needed for the UR to work.

Thus, replacing the Universal_Robots_ROS2_Driver/ur_robot_driver/resources/ros_control.urscript, from {{SERVER_IP_REPLACE}} to my host IP, fixed the problem.

PS: Remember to run it in this order: 1. Launch the ur_control launch file 2. Start the program in the real UR 3. Launch the ur_moveit launch file

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2022-06-23 05:58:57 -0600

Seen: 202 times

Last updated: Jun 28 '22