ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
1

Unable to locate package ros foxy desktop

asked 2022-06-20 12:38:59 -0500

DYT1353 gravatar image

I'm trying to install the ROS2 foxy and when I input

sudo apt install ros-foxy-desktop

I get an error:

**Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

E: Unable to locate package ros-foxy-desktop**

My system is 64 bit so I'm not sure what the problem may be.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2022-06-20 22:16:22 -0500

electrophod gravatar image

Follow the instructions given here: https://docs.ros.org/en/foxy/Installa...

Also, ensure that you're installing ROS2 Foxy on Ubuntu 20.04

edit flag offensive delete link more
0

answered 2022-11-18 09:23:38 -0500

fabbro gravatar image

I also went (stupidly) through this for a specific reason: I was using ubuntu 20.04 until few weeks ago and I use ROS2 in Docker containers based on Ubuntu 20.04 then I moved to 22.04 and I was blindly installing ROS2 foxy. Instead, of course I should have been using ROS2 Humble. Check this. I hope this helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-06-20 12:38:59 -0500

Seen: 2,755 times

Last updated: Nov 18 '22