ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

colcon build fails humble

asked 2022-06-10 18:59:25 -0600

r_gerson gravatar image

updated 2022-06-10 18:59:39 -0600

when i run colcon build, it fails because there is a syntax error. But i deleted the file containing the syntax error, moveMotor.py. That file used to be in :

~/Documents/my_robot/ros_ws/src/test1/test1

When i run colcon build, it errors because it finds that file in

~/Documents/my_robot/ros_ws/install/test1/lib/python3.10/site-packages/test1/moveMotor.py

When i delete it and run colcon build again, that file is regenerated, and colcon build again fails! what do i do?

i double checked that my package.xml and setup.py make no reference to moveMotor

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-06-10 19:04:25 -0600

r_gerson gravatar image

i fixed the issue by removing the build, install, and log directories

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-06-10 18:59:25 -0600

Seen: 209 times

Last updated: Jun 10 '22