ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rviz2: error while loading shared libraries

asked 2022-06-07 08:36:22 -0600

Orpiczy gravatar image

updated 2022-06-07 08:49:33 -0600

I can not run rviz2 due to lack of shared library, I tried to install it with

sudo apt-get install libogre1.12.10

but it doesn't help

full error msg

user@pc:~$ rviz2
rviz2: error while loading shared libraries: cannot open shared object file: No such file or directory

For any suggestions I would be eternally grateful : )

system: ubuntu 22.04, ros2codename: humble

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2023-03-23 10:23:23 -0600 gravatar image

sourcing humble again fixed it to me.

source /opt/ros/humble/setup.bash
edit flag offensive delete link more

answered 2022-06-08 04:34:29 -0600

Orpiczy gravatar image

I just waited for update, that was it, simple bug apparently or stuff as trivial as tuning on and off PC

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2022-06-07 08:36:22 -0600

Seen: 1,845 times

Last updated: Jun 08 '22