No map frame is published when setting use_sim_time_true

asked 2022-05-02 15:15:19 -0500

Javad_0111 gravatar image

Hi all,

I am using Realsense L515 camera and RTAB-MAP for creating maps. I recorded a bag file not to use my camera for every simulation. As I am using a bag file, I should do "rosparam set use_sim_time true" to simulate based on bag file's clock. However, when I follow the steps below, no map frame is published! When use_sim_time is not true, the map frame and map will be generated pretty good. I would appreciate it if someone could tell me the problem. If you need further information, do not hesitate to contact me. Thanks.

rqt_graph

launch file

view_frames

The steps that I follow are :

1) roscore

2) rosparam set use_sim_time

3) launch file

4) rosbag play ~/Myfile/Thesis_bag_files/l515_with_aruco.bag --topics /camera/aligned_depth_to_color/image_raw /camera/color/camera_info /camera/color/image_raw /camera/color/image_raw/compressed /clock /tf_static --clock

edit retag flag offensive close merge delete

Comments

2

Should be rosparam set use_sim_time true, and why setting --topics? you may miss camera_info and /tf, /tf_static topics.

matlabbe gravatar image matlabbe  ( 2022-05-09 11:07:43 -0500 )edit

Thanks for the reply. I have another bag file, and I did the same simulation without --topic filters, but I still have the same problem. After sharing this issue here, I found out that the same problem exists with rtabmap demo.bag. I shared this issue, here.

Javad_0111 gravatar image Javad_0111  ( 2022-05-09 12:12:01 -0500 )edit