ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

RQT ROS2 Galactic not plotting or autoscrolling.

asked 2022-04-06 02:10:37 -0500

MasHyke gravatar image

Hi guys,

I am getting this weird bug in RQT. I am trying to plot values from two different topics that RQT subscribes to, but the plot stands still. Whatever I do, I am not getting any values plotted, and the plot itself is not moving even though I have autoscroll on. I had the same error using ROS2 Foxy. I did a complete uninstall of ROS2 Foxy and installed ROS2 Galactic, but the problem persists.

In the terminal window where I launch RQT, I get this error message:

Traceback (most recent call last): File "/opt/ros/galactic/lib/python3.8/site-packages/rqt_topic/topic_widget.py", line 453, in __lt__ return self.data(column, Qt.UserRole) < other_item.data(column, Qt.UserRole) TypeError: '<' not supported between instances of 'NoneType' and 'NoneType'

Has anyone else encountered this error as well?

ROS_VERSION=2

ROS_PYTHON_VERSION=3

ROS_LOCALHOST_ONLY=0

ROS_DISTRO=galactic

Ubuntu 20.04.3 Linux 5.14.0-1031-oem x86_64

edit retag flag offensive close merge delete

Comments

1

Could you try running rqt --clear-config, and reopening the widget? RQt stores configurations between sessions, and this command clears out those configurations.

ijnek gravatar image ijnek  ( 2022-04-06 02:19:27 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-04-06 02:55:19 -0500

MasHyke gravatar image

Running rqt --clear-config solved the issue!

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2022-04-06 02:10:37 -0500

Seen: 268 times

Last updated: Apr 06 '22