Ask Your Question
1

openni_node.launch not found

asked 2012-07-25 12:08:50 -0500

DonaldV gravatar image

updated 2012-07-25 12:09:53 -0500

I installed ROS on my Ubuntu 12.04 64-bit to work with RGBDSLAM. I followed all the instructions, installed ros-fuerte-openni-camera when it was not found. But after installing it, when I run roslaunch rgbdslam kinect+rgbdslam.launch, I get the following error

while processing /opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch:
Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch'

Please help me.

With regards Don

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-07-25 15:51:56 -0500

openni_camera/launch/openni_node.launch got deprecated with Fuerte. You'll have to do a bit of work to migrate. Take a look at the corresponding migration guide http://ros.org/wiki/openni_camera_deprecated#Migration_guide.

edit flag offensive delete link more

Comments

Note: there seems to be a bug in the launch script in the openni_camera_deprecated package. https://kforge.ros.org/openni/trac/ticket/51

piyushk gravatar image piyushk  ( 2012-08-01 19:40:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-25 12:08:50 -0500

Seen: 1,080 times

Last updated: Jul 25 '12