Ask Your Question
0

Invoking "make cmake_check_build_system" ERROR !

asked 2022-03-28 03:46:48 -0500

emrebaba54 gravatar image

I'm having a problem with catkin_make command in my workspace. This happened after I have been trying to install mavros. although, I ran "catkin_make_isolated" and i am facing error but I don't know how to identify which files are "non-catkin packages". If I remove these "non-catkin packages" would it fix the problem? I've looked in the CMakeOutput.log and CMakeError.log but I don't know what I should be looking for. Thank you in advance. I believe that, this problem depends on "geographiclib-dev" because before i've looked some unstable version err*.

my terminal print is :

cm (this is alias and consist cd catkin_ws && catkin_make )

Base path: /home/emre/catkin_ws Source space: /home/emre/catkin_ws/src Build space: /home/emre/catkin_ws/build Devel space: /home/emre/catkin_ws/devel Install space: /home/emre/catkin_ws/install

#

Running command: "cmake /home/emre/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/emre/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/emre/catkin_ws/install -G Unix Makefiles" in "/home/emre/catkin_ws/build"

#

-- Using CATKIN_DEVEL_PREFIX: /home/emre/catkin_ws/devel -- Using CMAKE_PREFIX_PATH: /home/emre/overlay_ws/devel;/opt/ros/noetic -- This workspace overlays: /home/emre/overlay_ws/devel;/opt/ros/noetic -- Found PythonInterp: /usr/bin/python3 (found suitable version "3.8.10", minimum required is "3") -- Using PYTHON_EXECUTABLE: /usr/bin/python3 -- Using Debian Python package layout -- Using empy: /usr/lib/python3/dist-packages/em.py -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /home/emre/catkin_ws/build/test_results -- Forcing gtest/gmock from source, though one was otherwise available. -- Found gtest sources under '/usr/src/googletest': gtests will be built -- Found gmock sources under '/usr/src/googletest': gmock will be built -- Found PythonInterp: /usr/bin/python3 (found version "3.8.10") -- Using Python nosetests: /usr/bin/nosetests3 -- catkin 0.8.10 -- BUILD_SHARED_LIBS is on -- BUILD_SHARED_LIBS is on -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- ~~ traversing 43 packages in topological order: -- ~~ - cartographer (plain cmake) -- ~~ - hector_geotiff_launch -- ~~ - hector_slam (metapackage) -- ~~ - hector_slam_launch -- ~~ - mavlink (plain cmake) -- ~~ - libmavconn -- ~~ - cartographer_ros_msgs -- ~~ - hector_map_tools -- ~~ - hector_nav_msgs -- ~~ - turtlebot3 (metapackage) -- ~~ - turtlebot3_autorace (metapackage) -- ~~ - turtlebot3_autorace_control -- ~~ - turtlebot3_autorace_core -- ~~ - turtlebot3_msgs -- ~~ - turtlebot3_navigation -- ~~ - turtlebot3_simulations (metapackage) -- ~~ - hector_geotiff -- ~~ - hector_geotiff_plugins -- ~~ - hector_marker_drawing -- ~~ - iq_sim -- ~~ - opencv_uygulama -- ~~ - hector_compressed_map_transport -- ~~ - mavros_msgs -- ~~ - rplidar_ros -- ~~ - mavros -- ~~ - hector_imu_attitude_to_tf -- ~~ - hector_imu_tools -- ~~ - hector_map_server -- ~~ - hector_trajectory_server -- ~~ - hector_mapping -- ~~ - turtlebot3_autorace_camera -- ~~ - turtlebot3_autorace_detect -- ~~ - turtlebot3_bringup -- ~~ - turtlebot3_example -- ~~ - turtlebot3_fake -- ~~ - turtlebot3_gazebo -- ~~ - turtlebot3_slam -- ~~ - turtlebot3_teleop -- ~~ - mavros_extras -- ~~ - cartographer_ros -- ~~ - cartographer_rviz -- ~~ - test_mavros -- ~~ - turtlebot3_description -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ CMake Error at /opt/ros/noetic/share/catkin/cmake/catkin_workspace.cmake:100 (message): This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation. Try the 'catkin_make_isolated' command instead. Call Stack (most recent call first): CMakeLists.txt:69 (catkin_workspace)

-- Configuring incomplete, errors occurred! See also "/home/emre/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/emre/catkin_ws/build/CMakeFiles/CMakeError.log". Invoking "cmake" failed

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-04-01 00:34:44 -0500

emrebaba54 gravatar image

Hey Guys ! I haven't yet any excatly solution about this topic. Thus, i re-created the my workspace.

Although most of packages have been deleted but problem has been solved.

I believe that, this problem has based on unstable depencies. Creating a new workspace might work. Sincerely.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-03-28 03:46:48 -0500

Seen: 391 times

Last updated: Apr 01