RenderingAPIException: OpenGL 1.5 is not supported in GLRenderSystem

asked 2022-03-13 10:41:46 -0500

Pomorondža gravatar image

Hi, I am running on Linux with WSL, where I installed OpenGL and the other tools, I have this version currently: OpenGL version string: 1.4 (3.3 (Compatibility Profile) Mesa 22.0.0-devel When I start the ros2 run rviz2 rviz2, I get an error:

[ERROR] [1647185713.947699400] [rviz2]: RenderingAPIException: OpenGL 1.5 is not supported in GLRenderSystem::initialiseContext at /home/jenkins-agent/workspace/ci_packaging_linux/ws/build/rviz_ogre_vendor/ogre-v1.12.1-prefix/src/ogre-v1.12.1/RenderSystems/GL/src/OgreGLRenderSystem.cpp (line 1201)
[ERROR] [1647185713.947978000] [rviz2]: rviz::RenderSystem: error creating render window: RenderingAPIException: OpenGL 1.5 is not supported in GLRenderSystem::initialiseContext at /home/jenkins-agent/workspace/ci_packaging_linux/ws/build/rviz_ogre_vendor/ogre-v1.12.1-prefix/src/ogre-v1.12.1/RenderSystems/GL/src/OgreGLRenderSystem.cpp (line 1201)

Can someone assist me with this? Thanks in advance.

edit retag flag offensive close merge delete