ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

LIDAR Velodyne VLP16 Networking Issues

asked 2022-03-10 07:02:09 -0500

risbo6 gravatar image

updated 2022-03-10 07:03:21 -0500

Hello,

I'm having (networking?) issues with the Velodyne VLP-16 and I'm not sure what I'm doing wrong.

I'm connected to the same local network as the lidar, and I'm able to ping it. I've checked on the webpage the IP and the port of the LIDAR, but I'm getting a poll() timeout + failed to poll device.

I'm using the following launch command :

roslaunch velodyne_pointcloud VLP16_points.launch device_ip:=192.168.0.11 port:=2379

I've tried to turn off my firewall and it's still not working.

I'm providing some screenshots that show what's happening : https://imgur.com/a/Ri8L1Zd

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-03-10 18:34:59 -0500

Mike Scheutzow gravatar image

You don't need to specify a device_ip unless you have multiple lidars transmitting on the same IP port. This would be very unusual.

By default a velodyne device broadcasts UDP packets on port 2368. Why are you using the value 2379?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2022-03-10 07:02:09 -0500

Seen: 290 times

Last updated: Mar 10 '22