ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

rviz2 not loading "Entry Point Not Found"(Windows)

asked 2022-03-05 16:10:19 -0600

ncr7 gravatar image

I'm not sure if this is a simple error... getting back into ROS after being away for 7 years or so. Maybe I need to setup a PC with Ubuntu again.. but thought I'd try with Windows 10 first.

I've followed the install steps for everything listed in the ros installation guide page, I've installed chocolaty and ROS Foxy using the Windows(alternate install method)

Everything seems to install fine, I can run the Talker and Listener, Turtle Sim Example, but RViz2 isn't working.

I get two "Entry Point Not Found" errors, both .dll's are located in the directories shown in the erros.

Error1:

" The procedure entry point ?hasEdgeList@MovableObject@Ogre@@UEAA_NXZ could not be located in the dynamic link library C:\opt\ros\foxy\x64\bin\rviz_common.dll. "

Error 2:

" The procedure entry point ?coulour@ManualObject@Ogre@@UEAAXAEBVColourValue@2@@Z could not be located in the dynamic link library C:\opt\ros\foxy\x64\bin\rviz_rendering.dll. "

I've tried setting my paths as I've seen in another ROSAnswers forum post

Using that post I tried running my workspace setup with an admin CMD window thinking maybe it could fix a path issue.

Below is what I used as my workspace setup, but it didn't change any issues since I think they were pointing to the correct location already.


call "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\VsDevCmd.bat" -arch=amd64 -host_arch=amd64

SET Qt5_DIR=C:\Qt\5.15.0\msvc2019_64

SET QT_QPA_PLATFORM_PLUGIN_PATH=C:\Qt\5.15.0\msvc2019_64\plugins\platforms

SET "ChocolateyInstall=C:\ProgramData\chocolatey"

SET "PATH=C:\python38; C:\python38\scripts; C:\opt\ros\foxy\x64\bin; C:\opt\ros\foxy\x64\lib;%PATH%"

SET "PYTHONHOME=c:\Python38"

SET "PYTHONPATH=c:\Python38\lib\site-packages;c:\opt\ros\foxy\x64\lib\site-packages"

edit retag flag offensive close merge delete

Comments

@ncr7 did you resolve this? I'm having similar startup issues with rviz2.

jdlangs gravatar image jdlangs  ( 2022-05-25 12:27:11 -0600 )edit

I am having the same issue, but never happened to me before...

marpeja gravatar image marpeja  ( 2022-06-02 18:28:19 -0600 )edit

Did anyone solve this?

marpeja gravatar image marpeja  ( 2022-07-28 09:18:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-06-18 10:54:18 -0600

joez85 gravatar image

Hi, was having the same problem, the command "ros2 run rviz2 rviz2" works for me. Try checking it out.

edit flag offensive delete link more

Comments

Been away a while... ended up loading Ubuntu :) Your solution worked for me.

ncr7 gravatar image ncr7  ( 2022-08-30 20:34:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-03-05 16:10:19 -0600

Seen: 236 times

Last updated: Mar 05