ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

How to attach OnRobot RG2 with UR10?

asked 2022-01-26 02:54:13 -0500

HynRidge gravatar image

updated 2022-01-27 01:09:39 -0500

I am new to ROS and I have been looking for ways to attach any OnRobot gripper to UR10 robot arm. I've tried to cloning the repo from https://github.com/sharathrjtr/ur10_rg2_ros.

While try to make the package, I encounter a few problems with some of the .cpp files. I ignore the the problems by copying the necessary urdf file to a universal_robot package.

From there on, I tried to run a moveit_setup_assistant. However, I always failed to load the .urdf.xacro files due to some undefined property in the .urdf.xacro files.

Here's the example of the error: image description

And here's the related .xacro.urdf files:

ur10_gr2_robot_arc.urdf.xacro

<?xml version="1.0"?>
<robot xmlns:xacro="http://www.ros.org/wiki/xacro"
       name="ur10" >

  <property name="M_PI" value="3.14159265359"/>
  <property name="kinect_prefix" value=""/>
  <property name="robot_prefix" value=""/>

  <!-- common stuff -->
  <xacro:include filename="$(find ur_description)/urdf/common.gazebo.xacro" />

  <!-- ur5 -->
  <xacro:include filename="$(find ur_description)/urdf/ur10.urdf.xacro" />

  <!-- kinect -->
  <xacro:include filename="$(find ur_description)/urdf/kinect.urdf.xacro" />

  <!-- arm extras -->
  <xacro:include filename="$(find ur_description)/urdf/arm_extras_ur10.urdf.xacro" />

  <!-- rg2 gripper -->
  <xacro:include filename="$(find ur_description)/urdf/rg2.urdf.xacro" />

  <!-- arm -->
  <xacro:ur10_robot prefix="" joint_limited="false"/>

  <!-- 3D sensor -->
  <xacro:sensor_kinect prefix="" parent="${kinect_prefix}kinect_back_link"/>

  <!-- arm extras -->
  <xacro:arm_extras prefix="" joint_limited="false" kinect_prefix="${kinect_prefix}"/>

  <!-- rg2 pipe -->
  <xacro:rg2 prefix=""/>

  <!-- world will be root link-->
  <link name="world" />
  <joint name="world_joint" type="fixed">
    <parent link="world" />
    <child link = "ground_base1" />
    <origin xyz="0.0 0.0 0.0" rpy="0.0 0.0 0.0" />
  </joint>

</robot>

I have tried changing the property name within this files and the other related files, but none of the attempt seems to solve the issues. It would be much appreciated if anyone knows how to solve this issue.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-02-04 02:10:06 -0500

HynRidge gravatar image

updated 2022-02-06 19:15:00 -0500

This question is not solved but it seems like there has been some outdated drivers (which doesn't works well in noetic distributions of the gr2 gripper). Hence, I wouldn't recommend anyone with no much experience to try to setup UR10 + GR2 under noetic distributions as the troubleshooting process is quite complicated (I have not found the solution).

The way I solved it is to move my setup to the Melodic distributions!!

edit flag offensive delete link more

Comments

Thank you for sharing

osilva gravatar image osilva  ( 2022-02-04 04:57:04 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2022-01-26 02:54:13 -0500

Seen: 353 times

Last updated: Feb 06 '22