Ask Your Question
1

Not all paths in ROS_PACKAGE_PATH[a series of ros package path] point to an existing directory:

asked 2012-07-22 19:11:37 -0600

updated 2014-01-28 17:13:06 -0600

ngrennan gravatar image

Hi,

I always come across with the problem that Not all paths in ROS_PACKAGE_PATH [/home/lilimeng/fuerte_workspace/turtlebot:/home/lilimeng/fuerte_workspace/sandbox:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros] point to an existing directory: * /home/lilimeng/fuerte_workspace/turtlebot

when I install segway_rmp and openni_kinect in my fuerte ROS in Ubuntu12.04. I have tried several times, such as ROS_PACKAGE_PATH=/home/lilimeng/fuerte_workspace/turtlebot, but it didn't work!!!

Looking for your help! I highly appreciate it!

edit retag flag offensive close merge delete

Comments

Do all of the paths (specifically /home/lilimeng/fuerte_workspace/turtlebot ) actually exist and you have permissions to read from those paths?

Eric Perko gravatar imageEric Perko ( 2012-07-22 19:32:08 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-22 20:32:11 -0600

I got the answer, as the /home/lilimeng/fuerte_workspace/turtlebot does not exist. So I just changed to export ROS_PACKAGE_PATH=/home/lilimeng/fuerte_workspace/sandbox:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros.

It finally works

edit flag offensive delete link more
2

answered 2012-07-22 21:52:08 -0600

Lorenz gravatar image

It is not recommended to manage the ROS_PACKAGE_PATH variable manually. The best way to keep ROS_PACKAGE_PATH organized and clean is to use rosws. Have a look at this page for a quick tutorial.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-22 19:11:37 -0600

Seen: 827 times

Last updated: Jul 22 '12