Ask Your Question
0

IPV6-Problems: [registerService] Failed to contact master at [server:11311]. Retrying...

asked 2022-01-10 14:12:25 -0500

Raph gravatar image

Heyho, somehow using

export ROS_IPV6=on

in Docker doesn't work and gives the error message in the title: [registerService] Failed to contact master at [server:11311]. Retrying...

ROS-Version: Melodic Host System: Ubuntu 20.04.3 LTS Docker-Version: 20.10.12

Steps to reproduce:

docker pull osrf/ros:melodic-desktop-full
docker run -it --rm --net=host osrf/ros:melodic-desktop-full /bin/bash
export ROS_IPV6=on
roscore

Output:

... logging to /root/.ros/log/2bae647e-7251-11ec-85b6-b42e99464746/roslaunch-server-35.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://server:46123/
ros_comm version 1.14.11


SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.11

NODES

auto-starting new master
process[master]: started with pid [45]
ROS_MASTER_URI=http://server:11311/

setting /run_id to 2bae647e-7251-11ec-85b6-b42e99464746
process[rosout-1]: started with pid [56]
started core service [/rosout]
[ERROR] [1641845350.101209283]: [registerService] Failed to contact master at [server:11311].  Retrying...

Any pointers?

edit retag flag offensive close merge delete

Comments

Just tried directly on a pc, it shows the same problem.

Raph gravatar image Raph  ( 2022-01-10 14:44:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-01-11 03:47:07 -0500

Raph gravatar image

Found the solution: You also need to set ROS_HOSTNAME to the correct one with export ROS_HOSTNAME=$HOSTNAME

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2022-01-10 14:12:25 -0500

Seen: 25 times

Last updated: Jan 11