ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Issues: Motion Planning & Trajectory Waypoints

asked 2022-01-07 00:41:56 -0500

ramdas369rd gravatar image

I'm following MoveIt Quickstart in RViz tutorial. I chose the Specific Start/Goal States then I pressed "Plan" from the Motion planning panel but it didn't change anything or show the trajectory path.

Also in Motion Planning Slider, the waypoint is still numbered 0. I set the start/goal of the robot arm to a different location without any collision.

Does anyone know why I cant witness any changes when I press Plan?

I'm curious about the error I got when I ran "roslaunch panda_moveit_config demo.launch rviz_tutorial:=true". It still opened RVIZ and I was able to upload panda_arm(motion planning).

ERROR: cannot launch node of type [moveit_ros_move_group/move_group]: Cannot locate node of type [move_group] in package [moveit_ros_move_group]. Make sure file exists in package path and permission is set to executable (chmod +x)

ROS version: Noetic | Ubuntu 20.04.3 LTS

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2022-01-07 07:04:17 -0500

osilva gravatar image

Most likely your MoveIt package didn’t build properly.

Start by checking if the package is there:

rospack find moveit_ros_move_group

If it’s present, then you may need to look at reinstalling, try using apt instead.

Reference: https://github.com/ros-planning/movei...

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2022-01-07 00:41:56 -0500

Seen: 325 times

Last updated: Jan 07 '22