Ask Your Question
1

[process has died exit code -11] error

asked 2021-12-27 20:22:18 -0500

yun gravatar image

updated 2022-02-18 13:22:28 -0500

lucasw gravatar image

Hi I have critical problem..please solved it. The site I was referring to is https://github.com/MrLacquer/hj-objec... I guess there is a problem with the pcl package, but i don't know the cause. Cant i solved it? Below is the full code..

hj@hj:~$   roslaunch hj_object_detect hj_jsk_test.launch 
... logging to /home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/roslaunch-hj-4055.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://hj:46807/

SUMMARY
========

PARAMETERS
 * /cluster_decomposer/approximate_sync: True
 * /cluster_decomposer/publish_tf: True
 * /cluster_decomposer/tf_prefix: yolo_
 * /rosdistro: melodic
 * /rosversion: 1.14.12

NODES
  /
    cluster_decomposer (nodelet/nodelet)
    detection_manager (nodelet/nodelet)
    label_mask (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

process[detection_manager-1]: started with pid [4128]
process[label_mask-2]: started with pid [4129]
process[cluster_decomposer-3]: started with pid [4132]
[ INFO] [1640657256.352385218]: Initializing nodelet with 6 worker threads.
**[ WARN] [1640657257.964271531]: [/detection_manager] '~input' has not been remapped.
[detection_manager-1] process has died [pid 4128, exit code -11, cmd /opt/ros/melodic/lib/nodelet/nodelet manager __name:=detection_manager __log:=/home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/detection_manager-1.log].
log file: /home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/detection_manager-1*.log**
[label_mask-2] process has finished cleanly
log file: /home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/label_mask-2*.log
[cluster_decomposer-3] process has finished cleanly
log file: /home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/cluster_decomposer-3*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done
edit retag flag offensive close merge delete

Comments

Hi @yun I reviewed the repo issues some are in Korean but with translate feature was understandable. I suggest you test components of the package first to help troubleshoot the issue as it could be the jsk or like you said issues with some of the dependencies.

The way to do this is comment part of the launch file until you get it working. Then try to isolate what is actually failing. Based on the error it looks it’s the detection manager.

https://github.com/MrLacquer/hj-objec...

osilva gravatar image osilva  ( 2021-12-30 19:33:39 -0500 )edit

Can you show the log please:

/home/hj/.ros/log/d6747a26-6782-11ec-afaa-40b076dd2030/detection_manager-1.log

osilva gravatar image osilva  ( 2021-12-30 19:54:23 -0500 )edit

link text I looked at the log, but I don't know what kind of error occurred..

yun gravatar image yun  ( 2022-01-02 01:42:00 -0500 )edit

What’s interesting from error log is that everything launches properly and fails when connecting to detection manager. The other clue is that the input has not remapped as prior warning. But why do you think is pcl?

osilva gravatar image osilva  ( 2022-01-02 11:48:10 -0500 )edit

To be precise, it seems to be a jsk pcl error. Everything else works fine, but when I run this part

<node pkg="nodelet" type="nodelet" name="label_mask" args="load jsk_pcl_utils/LabelToClusterPointIndices $(arg MANAGER)"> <remap from="~input" to="darknet_ros/label_image"/> <remap from="~output" to="darknet_ros/cluster_points"/> </node>

<node pkg="nodelet" type="nodelet" name="cluster_decomposer" args="load jsk_pcl/ClusterPointIndicesDecomposer $(arg MANAGER)"> <remap from="~input" to="$(arg point_cloud_topic)"/> <remap from="~target" to="darknet_ros/cluster_points"/> <rosparam>

, an error appears and I thought it was a jsk pcl error

yun gravatar image yun  ( 2022-01-02 22:23:00 -0500 )edit

Are you able to run detection without ROS. It may be easier to troubleshoot as the fault doesn’t help you much at the moment

osilva gravatar image osilva  ( 2022-01-03 06:26:30 -0500 )edit

It runs fine without ros.. I don't know the cause either, but I'll fix it. Thank you so much!

yun gravatar image yun  ( 2022-01-05 01:15:52 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2022-02-19 02:21:13 -0500

miura gravatar image

Isn't it possible to remap if there is a tilde like ~input? If you change the remap in the launch file from ~input to input or /namespace/input, it may seems to make progress.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-12-27 20:22:18 -0500

Seen: 633 times

Last updated: Feb 19