Ask Your Question
0

why openni packages are outdated?

asked 2012-07-19 22:24:26 -0500

Alireza gravatar image

Hi, Recently i have immigrated to ubuntu 12.04 for installing ros-fuerte and also using up to date versions of openni packages! but i saw that they are still outdated! the current release of openni is 1.5.2.23 and PrimeSense Nite is 1.5.2.21 but in ROS repositories its current version for openni is 1.4 and PrimeSense Nite is 1.3!! The Newest stable version of Nite does not need Calibration pose any more and its really great!

i dont know why these packages aren't updated yet!!!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-20 01:33:13 -0500

Lorenz gravatar image

Probably the maintainers of the openni ros packages didn't have time to update yet. Feel free to file a request at the corresponding issue tracker, ideally with a patch attached if necessary.

edit flag offensive delete link more
0

answered 2012-07-20 03:41:38 -0500

jbohren gravatar image

You can install the openni packages from http://www.openni.org/Downloads/OpenNIModules.aspx and build the openni_kinect ROS stack from source if you want to try the newer version of NITE. If there are compatibility issues, then you're welcome to submit a patch.

That being said, the only distribution of NITE 1.5 for 12.04 is currently "unstable" and it doesn't make much sense to redistribute v1.5 in ROS until it's stable.

edit flag offensive delete link more

Comments

I don't think its really related to being unstable or not, because a distribution of NITE 1.5 for ubuntu 10.10 is already exist in http://www.openni.org/Downloads/OpenNIModules.aspx, but it didn't updated in ubuntu 10.10 either! I will try to build the openni_kinect stack from the source anyway.

Alireza gravatar imageAlireza ( 2012-07-20 04:26:35 -0500 )edit

So how exactly should I get the latest openNI binaries working with the openni_kinect stack in ROS? I have installed the latest openNI binaries on a machine where the openni_kinect stack was working perfectly fine. However, once installed, none of the inbuilt programs such as openni_tracker works.

Nash gravatar imageNash ( 2012-07-31 19:52:09 -0500 )edit
1

If you install the OpenNI libs from openni.org and install them, yourself, then you also need to check out the source versions of openni_kinect, openni_camera, openni_launch, and openni_tracker and build them from source.

jbohren gravatar imagejbohren ( 2012-08-03 00:51:25 -0500 )edit

Thanks jbohren!, in addition to the above I had to re install the drivers. (similarly to this question: http://answers.ros.org/question/10188/kinect-with-openni_kinect-driver-not-working-after/)

Nash gravatar imageNash ( 2012-08-03 12:20:00 -0500 )edit

Did you test openni_tracker ? is it still needs calibration pose?

Alireza gravatar imageAlireza ( 2012-08-04 09:50:47 -0500 )edit

With the released drivers for even Ubuntu 10.10 and ROS Electric, the calibration pose is no longer needed.

jbohren gravatar imagejbohren ( 2012-08-04 23:05:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-19 22:24:26 -0500

Seen: 502 times

Last updated: Jul 20 '12