Robot's legs actuating but it isn't moving in gazebo (Moving in Rviz)

asked 2021-12-20 23:04:08 -0500

Aish11 gravatar image

updated 2022-02-11 11:38:58 -0500

lucasw gravatar image

Hello Everyone, I am working on simulating the spotmicro dog robot on Gazebo simulator with ROS. I am able to launch my robot on rviz using launch file bringup.launch and am able to make it walk using teleop in rviz. Also, I am able to launch the robot to gazebo simulator using launch file gazebo.launch, but I am not able to move the dog robot using teleop command (in gazebo simulator). The weird part of my problem is the legs of the robot is actuating as it should, when given walk command, but it is not able to make the dog robot move from it's place. The efforts I made to solve this problem are:- 1. Checked the mu (friction) values of the ground as well as leg of the robot. 2. Robot is not fixed with the world file (checked it by launching the bot in different gazebo worlds). 3. The mass of the robot is properly defined (it is not zero). 4. Visual elements, collision elements and inertial elements in the urdf file is properly defined.

The problems I was facing before coming this far were:- 1. Robot was not on the ground. I solved it by checking the collision element's z-axis value of bottom most part of each legs of dog robot. (SOLVED) 2. All the legs of the robots were collided with each other at the origin. And TF tree showed no link between base_link and all the shoulder links. (SOLVED)

I would really appreciate any helps and suggestions. Thanks in advance.

edit retag flag offensive close merge delete