Ask Your Question

micro-ros add_two_ints_service not working on Galactic with Zephyr

asked 2021-11-30 06:15:26 -0500

Jefecito gravatar image


I am studying Micro-ROS and Zephyr and just faced an issue with the demo app add_two_ints_service when running on ROS2 Galactic. It builds, flashes, and connects with the Agent OK, but, as soon as I send the first service call, it freezes and no response is sent back. I did the same test with ROS Foxy and it worked fine.

I've looked at the code of both branches and noticed that the code is the same. Do I need to change something to make this service work in Galactic?

I am facing the same issue in the application I am developing using custom messages. I started developing it successfully on Foxy but needed to migrate to Galactic because of the necessity for a Parameter service. So, I've started experiencing the same freezing issue with services. That's why I tried with the service demos to check.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-11-30 07:50:29 -0500

Pablogs gravatar image

Could you open an issue in the Github repo and link it here so we can track this problem?


edit flag offensive delete link more



I did it at the zephyr_apps rep.

You're welcome.

Jefecito gravatar image Jefecito  ( 2021-11-30 11:56:16 -0500 )edit

Solved using Fast-DDS in the ROS 2 side:

$ sudo apt install ros-galactic-rmw-fastrtps-cpp
$ export RMW_IMPLEMENTATION=rmw_fastrtps_cpp
Pablogs gravatar image Pablogs  ( 2021-12-01 02:56:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2021-11-30 06:15:26 -0500

Seen: 43 times

Last updated: Nov 30 '21