ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Kinect roslaunch error messages

asked 2012-07-18 07:15:20 -0500

bschreck gravatar image

updated 2016-10-24 09:03:27 -0500

ngrennan gravatar image

There have been several posts about this, but none seem to be fully resolved.

(I am using ROS fuerte on Ubuntu 12.04) I tried to install the openNI drivers (using sudo apt-get, rosdep install, and other things I found on different ROS answers pages), but I keep getting the same error when I try to do "roslaunch openni_launch openni.launch".

I get this error message:

[ERROR] [1342630897.153525834]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]

I also get a warning that it can't find my camera calibration file but that seems to not be much of an issue.

I tried (among other things), the first answer on with three terminals and loading rviz. Rviz loads, but with an error message in the Displays menu:

Fixed Frame
Fixed Frame [/map] does not exist

And I just get a black display instead of a "point cloud".

Anyone have any ideas? (by the way, I'm very new to ROS, if you couldn't tell)

There was also something about openni_node, (when I tried to install that it told me it couldn't find it), but I think that was for the older version.

******Update** Now I see that after I run rviz, I get this error message, and I think this is why I get no data from the kinect:

[camera_nodelet_manager-1] process has died [pid 10040, exit code -6, cmd /opt/ros/fuerte/stacks/nodelet_core/nodelet/bin/nodelet manager __name:=camera_nodelet_manager __log:=/home/ben/.ros/log/01490200-d113-11e1-a463-0016cb9a020f/camera_nodelet_manager-1.log].

log file: /home/ben/.ros/log/01490200-d113-11e1-a463-0016cb9a020f/camera_nodelet_manager-1*.log

edit retag flag offensive close merge delete


@jarvisschultz So I see what you mean about the Displays error not being a big deal-- I just fixed that. But the problem still exists that I don't see anything. Now there is a Status:Warning thing under the PointCloud2 I made that says Topic: No messages received. Thanks for the quick response!

bschreck gravatar image bschreck  ( 2012-07-18 10:02:13 -0500 )edit

To test that the data is actually being sent from the Kinect, try using rostopic For example, in another terminal, type "rostopic hz /camera/depth/points" If this tells you that point clouds are being published at ~30Hz, then you simply have something wrong with your rviz configuration.

jarvisschultz gravatar image jarvisschultz  ( 2012-07-18 12:38:48 -0500 )edit

Thanks everyone- I can get data from the kinect now. However, in rviz, I get a very weird small image that doesn't really correspond to anything in the real world. I know that the camera and depth sensor are working though (running image_vew and disparity_view in another window).

bschreck gravatar image bschreck  ( 2012-07-19 07:49:25 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2012-08-10 10:09:54 -0500

ebeowulf gravatar image

Has there been any further news on this topic? It looks like the kinect still doesn't work reliably on 12.04?

edit flag offensive delete link more


I think that is too bold of a statement, it works with no problems on my 12.04 64 bit with Fuerte

jarvisschultz gravatar image jarvisschultz  ( 2012-08-10 17:51:14 -0500 )edit

Doesn't work for me either. I also run Ubuntu 12.04 64bit fresh updated.

Pitscho gravatar image Pitscho  ( 2012-08-14 10:30:55 -0500 )edit

answered 2012-07-18 22:25:10 -0500

Regarding the [ERROR] from openni_launch package complaining about trying to advertise a service that is already advertised, you can get rid of it following the instructions on this answer

edit flag offensive delete link more

answered 2012-07-18 07:34:13 -0500

As far as I know, with the new openni_launch package, the [ERROR] that you are reporting is quite common (I get it whenever I run the same command you posted). It really doesn't seem to affect anything.

The error that you are getting with rviz has to do with you not choosing a valid "Fixed Frame" for your display. In the "Displays" panel, be sure that under ".Global Options" your fixed frame is actually a frame that exists. For example, /camera_depth_optical_frame. Then you should be able to add a PointCloud2 display, and set the topic correctly (something like /camera/depth/points.)

edit flag offensive delete link more

answered 2012-07-18 23:01:28 -0500

rastaxe gravatar image

I think that if you follow the jarvisschultz's answer you will solve your problem. But check also that the XnSensorServer process is not running before launching openni, otherwise it will crash, see this post.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-07-18 07:15:20 -0500

Seen: 1,818 times

Last updated: Aug 14 '12