Ask Your Question
0

E: Unable to locate package ros-melodic-desktop-full or ros-melodic-desktop

asked 2021-11-15 17:32:47 -0600

jgauthier gravatar image

Hello,

I am attempting to follow the instructions for ROS installation on a Raspberry (http://wiki.ros.org/melodic/Installat...)

After setting up the repository I tried to run this:

sudo  apt install ros-melodic-desktop

Which resulted in this:

E: Unable to locate package ros-melodic-desktop

I took a look at /etc/apt/sources.list.d/ros-latest.list and I see:

deb http://packages.ros.org/ros/ubuntu stretch main

So I opened my trusty web browser to look at the repository. http://packages.ros.org/ros/ubuntu/di... And sure enough, "Packages" doesn't contain ANY ROS software.

However, arm64 does. But Raspbian isn't arm64.

I attempted a source install - ran into issues (Not covered here) I attempted a docker install - Ran into this same issue above using a buster image.

How is getting ROS installed achieved on a Raspberry Pi (32 bit system - and it's not upgradable)

edit retag flag offensive close merge delete

Comments

What type of Raspberry are you running? rpi 3B?

osilva gravatar image osilva  ( 2021-11-15 17:48:02 -0600 )edit

I have tried this procedure on a Raspberry Pi 3B running stretch. I have also tried this in a Debian Stretch armhf VM, as well as a docker container running Debian Buster (armhf)

jgauthier gravatar image jgauthier  ( 2021-11-15 17:52:10 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-11-15 18:08:43 -0600

updated 2021-11-15 18:12:23 -0600

Unfortunately with RPi 3B, you won't be able to install ROS melodic desktop easily in Raspbian. I suggest instead to install Ubuntu 20.04 ROS Noetic Core: https://ubuntu.com/download/raspberry...

Things to consider:

ROS Melodic End of Life: May 2023

ROS Noetic End of Life: May 2025

If you still need to run Melodic in your Rpi 3B use instead Ubuntu 18.04, follow this tutorial: https://roboticsbackend.com/install-r...

$ sudo apt install ros-melodic-ros-base

edit flag offensive delete link more

Comments

Unfortunately, I cannot reimage the card. It's vendor provided with vendor supplied software.
But I can install Docker and any armhf image. But without any armhf packages available the specific OS isn't going to matter - it won't work.

I'm confused how using Ubuntu 18.04 would solve the problem if the packages are missing from the armhf repository.

jgauthier gravatar image jgauthier  ( 2021-11-15 18:17:07 -0600 )edit

Understood. If you install from source then go for ‘ros-base’ not ros-desktop

osilva gravatar image osilva  ( 2021-11-15 18:21:55 -0600 )edit

Definitely. I would really like rviz on this platform for the end user.. but they might have to do without it (or use it from their Windows station remotely, which is also tricky, but doable). The 'viz' (REP 150) almost compiles... But I have an issue with opencv (not surprising). I might try and remove the components calling for it.

jgauthier gravatar image jgauthier  ( 2021-11-15 18:32:40 -0600 )edit

It’s Ubuntu Mate as per suggested tutorial: https://roboticsbackend.com/install-u...

osilva gravatar image osilva  ( 2021-11-15 18:36:51 -0600 )edit

Following the link you sent (https://roboticsbackend.com/install-r...) it says, "Any Ubuntu will do: Ubuntu server, Xubuntu, Ubuntu MATE, etc." But according to https://ubuntu-mate.org/raspberry-pi/, "Ubuntu MATE is available for Raspberry Pi with separate images for armhf (ARMv7 32-bit) and arm64 (ARMv8 64-bit). "

So, that won't work either because there are no ROS packages for armhf.

Good thought, glad I went down that trail.. But it seems like source is my only option.

Thanks!

jgauthier gravatar image jgauthier  ( 2021-11-15 18:44:57 -0600 )edit

RViz is tricky for sure but perhaps you can use Webviz. For OpenCv I’d install opencv-python only with pip

osilva gravatar image osilva  ( 2021-11-15 18:46:28 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-11-15 17:32:47 -0600

Seen: 58 times

Last updated: Nov 15 '21