Ask Your Question
0

hector indoor_slam_demo.launch failure

asked 2012-07-16 00:02:30 -0500

prince gravatar image

Greetings, I am in process of establishing hector_quadrotor simulation environment. Environment: Ubuntu Lucid, ROS Fuerte, hector_Slam stack from http://tu-darmstadt-ros-pkg.googlecode.com/svn/branches/fuerte . ROS Fuerte is installed using deb packages for Ubuntu. ros-fuerte-simulator-gazebo version 1.6.10-s134161751 is being used. After successfully compiling the various required packages, on launching, gazebo always dies! Following is the terminal output:

setting /run_id to f53a5b3c-cf58-11e1-b399-3cd92b6407b7
process[rosout-1]: started with pid [6513]
started core service [/rosout]
process[gazebo-2]: started with pid [6527]
process[gazebo_gui-3]: started with pid [6536]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

process[spawn_robot-4]: started with pid [6540]
process[robot_state_publisher-5]: started with pid [6549]
Msg Waiting for master.process[ground_truth_to_tf-6]: started with pid [6580]
[ WARN] [1342451678.877397996]: The root link base_link has an inertia specified in the URDF, but KDL does not support a root link with an inertia.  As a workaround, you can add an extra dummy link to your URDF.
Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345
[ INFO] [1342451678.900291126]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
process[hector_mapping-7]: started with pid [6623]
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  55 (X_CreateGC)
  Resource id in failed request:  0x4800002
  Serial number of failed request:  28
  Current serial number in output stream:  30
process[hector_trajectory_server-8]: started with pid [6658]
process[hector_geotiff_node-9]: started with pid [6723]
HectorSM map lvl 0: cellLength: 0.05 res x:2048 res y: 2048
HectorSM map lvl 1: cellLength: 0.1 res x:1024 res y: 1024
process[rviz-10]: started with pid [6747]
[ INFO] [1342451679.049206663]: No plugins loaded for geotiff node
[ INFO] [1342451679.049303993]: Geotiff node started
[ INFO] [1342451679.062075923]: HectorSM p_base_frame_: base_footprint
[ INFO] [1342451679.062154478]: HectorSM p_map_frame_: map
[ INFO] [1342451679.062172643]: HectorSM p_odom_frame_: nav
[ INFO] [1342451679.062196388]: HectorSM p_scan_topic_: scan
[ INFO] [1342451679.062215026]: HectorSM p_use_tf_scan_transformation_: true
[ INFO] [1342451679.062233934]: HectorSM p_pub_map_odom_transform_: true
[ INFO] [1342451679.062255121]: HectorSM p_scan_subscriber_queue_size_: 5
[ INFO] [1342451679.062276856]: HectorSM p_map_pub_period_: 2.000000
[ INFO] [1342451679.062296779]: HectorSM p_update_factor_free_: 0.400000
[ INFO] [1342451679.062316553]: HectorSM p_update_factor_occupied_: 0.900000
[ INFO] [1342451679.062335595]: HectorSM p_map_update_distance_threshold_: 0.400000 
[ INFO] [1342451679.062354975]: HectorSM p_map_update_angle_threshold_: 0.060000
[ INFO] [1342451679.062376253]: HectorSM p_laser_z_min_value_: -1.000000
[ INFO] [1342451679.062395483]: HectorSM p_laser_z_max_value_: 1.000000
loading model xml from ros parameter

Msg Connected to gazebo master @ http://localhost:11345


Error [Transport.cc:102] Unable to get topic namespaces in [50] tries.
Error [Node.cc:68] No namespace found
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2:  6539 Segmentation fault      `rospack find gazebo`/gazebo/bin/gzclient -g `rospack find gazebo`/lib/libgazebo_ros_paths_plugin.so
[gazebo_gui-3] process has died [pid 6536, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/nitin/.ros/log ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-16 00:37:47 -0500

I cannot reproduce the error. The launch file works on my machine, starting up both gazebo and rviz on fuerte. The only "slightly" annoying thing is the laser scan being mirrored from left to right, totally killing SLAM as soon as the UAV is rotated. As everything works in electric I suspect a bug in gazebo, will have to create a ticket for that.

What kind of graphics card are you using and can you start other scenarios in gazebo without crashing it?

edit flag offensive delete link more

Comments

Hardware is Nvidia Quadro 2000. lspci | grep VGA 0f:00.0 VGA compatible controller: nVidia Corporation Device 0dd8 (rev a1)

prince gravatar imageprince ( 2012-07-16 01:14:36 -0500 )edit

Hardware is Nvidia Quadro 2000. lspci | grep VGA 0f:00.0 VGA compatible controller: nVidia Corporation Device 0dd8 (rev a1)

prince gravatar imageprince ( 2012-07-16 01:14:38 -0500 )edit

Hi Stefan, I notice that the roll movement of the simulated quadrotor shown in rviz is the mirror of the same move in gazebo, is it the same issue you mean? And sometimes my laptop just suddenly shuts down when running the packages. (Ubuntu Precise + Fuerte + ATI HD 3650)

Mike Gao gravatar imageMike Gao ( 2012-07-16 05:48:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-16 00:02:30 -0500

Seen: 566 times

Last updated: Jul 16 '12