Ask Your Question
1

Ros node not subscribing to other computer

asked 2012-07-12 10:05:59 -0500

Rorry_Brenner gravatar image

updated 2014-01-28 17:12:59 -0500

ngrennan gravatar image

I'm running an application on two computers. The ROS_MASTER_URI on both is set to the master, and each ROS_HOSTNAME is set to itself. A node on the master computer subscribes to a topic /CmdController, which multiple nodes publish. However the node will only receive messages sent from other nodes on the master. When running 'rostopic echo /CmdController' on the master the computer it will print the messages sent from the other computer. Also rxgraph, run on the master, will show the nodes run on the other computer publishing /CmdController to the node running 'rostopic echo.' However, the actual connection between the one particular node on the master and any node run on the other computer is not formed. Any idea what would be causing this connection to not be formed?

edit retag flag offensive close merge delete

Comments

Don't have enough karma to comment on your answer. But yes, master and slave can ping eachother using either hostname or IP. I just tried setting ROS_IP instead and it looks like that fixed it anyway though. Thanks for the help!

Rorry_Brenner gravatar imageRorry_Brenner ( 2012-07-12 10:47:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-07-12 10:19:05 -0500

Lorenz gravatar image

Can you ping the slave computer from the master when using the hostname and the other way around? Try setting ROS_IP instead of ROS_HOSTNAME, just to be sure.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-12 10:05:59 -0500

Seen: 653 times

Last updated: Jul 12 '12