Can Raspberry Pi 4 run ROS

asked 2021-09-13 23:48:34 -0500

mistrysiddh gravatar image

Hello, I just purchased a raspberry pi 4 b+ 8GB model and in that, I have installed raspbian buster which is official os is for raspberry pi. I tried using the wiki page Raspbian but it not installing even I tried to format and install ROS2 on raspbian and ubuntu 20.04 LTS server but it's not installing through wikis instructions.

edit retag flag offensive close merge delete


Hi @mistrysiddh, can you post your exact problem. Because It is not clerar if it is an installation problem or a ROS configuration problem. How did you install the OS in the Raspberry, using PINN, NOOBS...? And what are the exact errors you found? The last time I worked with a raspberry I was able to install Ubuntu with NOOBS and apt the full distribution of the precompiled ROS version with no problems.

Weasfas gravatar image Weasfas  ( 2021-09-15 04:22:04 -0500 )edit

@Weasfas i changed from rasbian to Ubuntu 21.04 hirsute and in that, I get this error while update repositories

Ign:1 hirsute InRelease Hit:2 hirsute InRelease Err:3 hirsute Release 404 Not Found [IP: 80] Hit:4 hirsute-updates InRelease Hit:5 hirsute-backports InRelease Hit:6 hirsute-security InRelease Hit:7 https://brave-browser-apt-release.s3.... stable InRelease Reading package lists... Done E: The repository ' hirsute Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

mistrysiddh gravatar image mistrysiddh  ( 2021-09-15 12:15:11 -0500 )edit

@mistrysiddh There is not target platform of ROS1 or ROS2 for Ubuntu 21.04, that may be the cause the apt is unable to find precompiled binaries for your distribution. You may want to change your OS version to Ubuntu Focal and ROS Noetic or ROS2 Galactic.

Weasfas gravatar image Weasfas  ( 2021-09-15 13:59:00 -0500 )edit