Ask Your Question
3

[gazebo]unable to find rendering system [closed]

asked 2012-07-11 01:27:01 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi all , i am new to gazebo and when i run following command

$ gzserver

it gave me following errors :-

Gazebo multi-robot simulator, version 1.0.1

Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.

Released under the Apache 2 License.

http://gazebosim.org

Msg Waiting for master

Msg Connected to gazebo master @ http://localhost:11345

Exception [RenderEngine.cc:468] unable to find rendering system

Error [Rendering.cc:37] Failed to load the Rendering engine subsystem

unable to find rendering system

Exception [RenderEngine.cc:468] unable to find rendering system

Exception [Sensors.cc:39] Unable to load the rendering engine

terminate called after throwing an instance of 'gazebo::common::Exception'

Aborted (core dumped)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Sanket_Kumar
close date 2013-06-30 22:04:18

Comments

@coon i installed everything twice but its not working.....its giving me same error

Sanket_Kumar gravatar imageSanket_Kumar ( 2012-07-11 07:46:37 -0600 )edit

ok, which OS do you use ?

pkohout gravatar imagepkohout ( 2012-07-12 22:24:10 -0600 )edit

ubuntu 12.04

Sanket_Kumar gravatar imageSanket_Kumar ( 2012-07-13 08:56:58 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-07-11 01:32:33 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

have you installed all requirements with a okey version ? http://gazebosim.org/wiki/requirements

edit flag offensive delete link more
0

answered 2012-07-26 04:32:06 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have the same problem. I think the problem is ogre. I have tried many ways to install ogre and I tried different version of ogre, still it gives me this error message. Some people says it happens to ubuntu 11.04 and 12.04. I am using 12.04 and it is required to use it for my project. I am stuck :(

edit flag offensive delete link more

Comments

2

hey my problem was solved i think it may help u......the instruction of installing gazebo lead me to this problem.....i think u have downloaded their debian package...first remove it and then download source package from here http://gazebosim.org/downloads.html then install it...in my case it worked

Sanket_Kumar gravatar imageSanket_Kumar ( 2012-07-31 06:28:02 -0600 )edit
1

Hi, thanks! My problem is solved too. But the ogre was a headache, I installed it several times before gazebo really find where it is.

Cherry gravatar imageCherry ( 2012-08-08 04:59:51 -0600 )edit

Hi, may I know how exactly did u solve the problem? Is it by installing gazebo via source package? Could you please tell me the detailed steps in solving this problem? I need it for school work too. Thank you!

ChengXiang gravatar imageChengXiang ( 2012-08-21 02:00:17 -0600 )edit

Question Tools

3 followers

Stats

Asked: 2012-07-11 01:27:01 -0600

Seen: 1,115 times

Last updated: Jul 26 '12