Problem with installing ROS2, could not find Qt platform plugin.

asked 2021-08-27 13:45:02 -0500

OskarG gravatar image

Hello everyone. I'm new to ROS2 galactic and I've got few problems with installation on my PC Windows 10. I'm following this guide: to install ROS2 Galactic. Before I explain my main problem with Qt please let me ask some questions to assure I did everything before correctly as I'm complete beginner:

  1. First problem I had with ROS2 installation was at "DOWNLOADING ROS2" it's not specified what to do with '' where to unpack it, for now it is in the same folder as (both unpacked)

  2. When trying to call C:\dev\ros2\local_setup.bat it shows error:

    "[rti_connext_dds_cmake_module][warning] RTI Connext DDS environment script not found (\resource\scripts\rtisetenv_x64Win64VS2017.bat). RTI Connext DDS will not be available at runtime, unless you already configured PATH manually."

What worked for me was calling C:\dev\ros2\local_setup which caused this message to pop up: Run only scripts that you trust. While scripts from the internet can be useful, this script can potentially harm your computer. If you trust this script, use the Unblock-File cmdlet to allow the script to run without this warning message. Do you want to run C:\dev\ros2\local_setup.ps1?

but idk if it's correct solution or mistake that can cause errors later.

  1. Last thing (at least for now), when trying to run turtlesim, at point when I am supposed to write "ros2 run turtlesim turtlesim_node" in powershell I get error: qt.qpa.plugin: Could not find the Qt platform plugin "windows" in "B:\Qt\5.15.0\msvc2019_64\plugins\platforms" This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

I tried reinstalling Qt on disk C:\ where everything else is installed, but that didn't help, neither did installing newer versions. I currently have Qt 5.15.0 installed same as it says in the guide.

What can be the cause of those problems? I am probably missing something very simple or doing something really wrong, tried looking for answers on the internet but with my limited knowledge I couldn't solve these problems.

edit retag flag offensive close merge delete