Ask Your Question
0

How to fix catkin Depends error..? ROS2 galactic

asked 2021-08-19 00:58:24 -0500

krishan.iot.w gravatar image

updated 2021-08-19 02:33:03 -0500

gvdhoorn gravatar image

Console:

sx-VirtualBox:~/catkin_ws/src$ catkin_make
Command 'catkin_make' not found, but can be installed with:

sudo apt install catkin

sx-VirtualBox:~/catkin_ws/src$ sudo apt install catkin
[sudo] password for kris-x: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 catkin : Depends: python3-catkin-pkg (>= 0.4.14-2) but it is not going to be installed
**E: Unable to correct problems, you have held broken packages.**
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-08-19 02:32:35 -0500

gvdhoorn gravatar image

You cannot use Catkin with ROS 2.

edit flag offensive delete link more

Comments

Thank you gvdhoom for your answer. For me it is very useful.. I could have worked harder for it. If not..I am trying to make a URDF from fusion 360 and run it. I did not get the exact tutorial for that. Can I have a guide for that?

krishan.iot.w gravatar image krishan.iot.w  ( 2021-08-19 04:13:54 -0500 )edit

I would not be able to refer you to one, as I'm not aware of one.

gvdhoorn gravatar image gvdhoorn  ( 2021-08-19 04:27:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-08-19 00:58:24 -0500

Seen: 209 times

Last updated: Aug 19 '21